summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-02 06:22:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-02 06:22:45 +0200
commit86c06973cbed40ad9fcce9e85fa87f23588fc5ec (patch)
tree91d9f19aef7aefbfafdad80116e71024d6562578 /dev-python/botocore
parentmedia-libs/lsp-plugins: Stabilize 1.2.14 arm64, #928397 (diff)
downloadgentoo-86c06973cbed40ad9fcce9e85fa87f23588fc5ec.tar.gz
gentoo-86c06973cbed40ad9fcce9e85fa87f23588fc5ec.tar.bz2
gentoo-86c06973cbed40ad9fcce9e85fa87f23588fc5ec.zip
dev-python/botocore: Bump to 1.34.75
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.75.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 81c348062a7c..ccd3a18fcd0e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.34.64.gh.tar.gz 12774647 BLAKE2B a41493d400b0f4f406a144aa968f0111ef2fa4bd739e43c6db8dddf4b70cfe68c714ec16875b942078a4bf8b9bd3a2dc596ea403c6e7dec6b076dccac7167c4b SHA512 66b7abf68d560ef87c94fbcde2738d8ce2c5bbd265678fab80d04966cdf1559c1ea3401dbcc6ef8e3f183a45ea1c3d31def8f1ce2c39135a3c247e73a18082b3
DIST botocore-1.34.69.gh.tar.gz 12790282 BLAKE2B 3d12eb5eb8e85777b43b3774e783c907f05e50dfe93445920ee0f42a82857ba7a70c5641e3cbfc03ab05f81f7cd989ff79e332bf2ae192b9bf7b3b3cbe6e9c0e SHA512 b520c5d3c6ce2f1db3e8620e5f7c882ed8483928de1cb32d22eabe76262ed8658614a0b1db42ceff445f11b009c48ef9a5761490e5982154e14173750b9e2554
DIST botocore-1.34.74.gh.tar.gz 12820469 BLAKE2B e9d7a35e82aee30666952ea6f74d8d0f695efad2fd0da520b70fdd313cabf3aff6e67fa71543c630bcfb4b4f78f780321babaf118990d8136b79755beadd8a5a SHA512 f7d741bd86e249ae46a7f79828c8b63c66519f9ae203f1a14a17e126c22d9e3d94710f5f5992f057491d3f7e41c7ea180255e1f766dc3bdee96ddb2ac6e28312
+DIST botocore-1.34.75.gh.tar.gz 12864283 BLAKE2B bc5a64b704e1ae4ceebfe65d748e2e904a151343fe4543ceea1955f8d06521b2f562ee75e0384d187c7fde9f7b5d79d5f02e323059ccd9ad332416deb27de066 SHA512 21847f64ce8f6cb6732f57de6f9d53b00b0ca0d669e6cac2b0edf1a3431c0d5081e6fd7c1c7cb6d664aec7fcb2d0d5b359a40a4abfda2767bbf27f43589eaed2
diff --git a/dev-python/botocore/botocore-1.34.75.ebuild b/dev-python/botocore/botocore-1.34.75.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.75.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}