summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-09-14 21:20:13 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-09-15 15:04:02 +0100
commitae68b9be023d490a9226687d32147fe98e9272fa (patch)
tree40d9e4e331db314897ef152621845b162f6ad30f /dev-python/botocore
parentdev-python/botocore: EAPI=7 (diff)
downloadgentoo-ae68b9be023d490a9226687d32147fe98e9272fa.tar.gz
gentoo-ae68b9be023d490a9226687d32147fe98e9272fa.tar.bz2
gentoo-ae68b9be023d490a9226687d32147fe98e9272fa.zip
dev-python/botocore: add new version 1.12.4
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.12.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index a17ef2063200..06aa7ac7a8be 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,4 +1,5 @@
DIST botocore-1.10.19.tar.gz 4372030 BLAKE2B cf4782e603c3483583edc2bd0a310781a00678524b4966b504e34db24b0f177d2d63cc76a5b2f1efa2d831c8ca3bc93f6bbbb628344da944a59b784cbd2e3062 SHA512 450f66d182f0262ae5fe040fc45c640c13fc2b9b1e4331e3be18ebd7b52b0008cb39f7293e243b101797a84b390399c09952f82880d925ebc076672282334577
DIST botocore-1.10.35.tar.gz 4451806 BLAKE2B 1161e5dc23a2a540b9fa237eb5c3029c6822bf76cc833be44366385482617ed64458a04ecd67ea9884d8b8a5b74e4b2a6232fb2f8d960118fba70860526fb4f0 SHA512 ea9e4bba6be53696fc4e3cf68e67f9e6eeaeda813c48d725e20f7170228f1cf8b55a023dd5fdb020290f5d6ecd10f75217e9327c928edacf8723dbd4050188d5
+DIST botocore-1.12.4.tar.gz 4800384 BLAKE2B 121019d3c33872fdd874ddba36ecc8612a6354068ce7b759cbe7f35a9787e84c34d3a71ef3fdd2d721d3c3973a7600e4398cb7cd2a3ba698464c15137845bdf3 SHA512 8d196984f5623df403a8a23a9b7e7061e59c0ca56103f89d749d6ad7d92168ccae267f85312f2949cee322776d7948f1ecfda3d9d2783e8ba92fde7a178e8cac
DIST botocore-1.7.39.tar.gz 3838231 BLAKE2B 53355a6f0fca131db8ae41ff7e0b5405dc2a4c1a0630743ec34e0fabe60468d27ea9d36b67dc3b8757c3f524eabf3fef1e55d3eb0df1f4c5bd229448f8dfc3d4 SHA512 0a6031315356f43e00ba5661020890478a589f0524bacd22fd24a9f8da147761f70d7b7fae9aab887301e78a392bc12dc7067174af9a07aac346d11a4cec9a22
DIST botocore-1.8.41.tar.gz 4196554 BLAKE2B 8f74b8f53fb98ea0fbadebb1739799eb30fb52748377175e0682292f4868910a5fab187c9065434e67d783eee0bb119555daa55020f1b909370749dfdf1dbc87 SHA512 d8bb3eb704268410646c0290fde829a3f69fc9c587b31afb43649efe345f626dc902be0ba7939239bb93871138aeb7587671dcb91ac40f4241c90b2238219d30
diff --git a/dev-python/botocore/botocore-1.12.4.ebuild b/dev-python/botocore/botocore-1.12.4.ebuild
new file mode 100644
index 000000000000..82cc15e1a9c7
--- /dev/null
+++ b/dev-python/botocore/botocore-1.12.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}