summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-09 15:33:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-09 16:01:32 +0100
commitce7cdfc2f9492d814854598a751de06581b8804d (patch)
tree492526195da3ecd09c13689b0cd17f5f05ca9aea /dev-python/botocore
parentnet-firewall/shorewall: bump to v5.2.3.7 (diff)
downloadgentoo-ce7cdfc2f9492d814854598a751de06581b8804d.tar.gz
gentoo-ce7cdfc2f9492d814854598a751de06581b8804d.tar.bz2
gentoo-ce7cdfc2f9492d814854598a751de06581b8804d.zip
dev-python/botocore: bump to v1.15.16
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.15.16.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index ec3083a4424f..76ab8ca1b05a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,4 +3,5 @@ DIST botocore-1.13.46.tar.gz 6069713 BLAKE2B 9d10fc46314f379ed384f2803d4bf43b10e
DIST botocore-1.13.50.tar.gz 6076129 BLAKE2B c969ba8635970eb7613124cafa3f7d1efaeec22699857405450a5e669f19733cf3328839d8dc568b7b46d0e2c05a3a649d97805dcb50e047c455bfbb9fc32901 SHA512 8c7fb409f9d1cd47f2711cc5cd34e7459087b50cd257d4f943b475d195ac141e01c3be53194cdb045d6ccf4ea59fdb2e485899275bb3185e6e562318615ec14b
DIST botocore-1.14.17.tar.gz 6117447 BLAKE2B 7b0e357c8b88c45f320a41cca602bec509ef0c9958b47448a8470aed81cde1cceaec975028c3793f53e9580ff34ce8df19e9d3914674eff5225b0578afe9edb5 SHA512 e3211bd27ad595c4c85144267333520bc365cfa2c7329da3ef431efacaa1e5d94777700ec248188497ef5782c00632872cbacc920c02eec2c143cecbd7154e17
DIST botocore-1.14.7.tar.gz 6092020 BLAKE2B 925b78a9414154838b4997da90a7916036a520725a99d187139250db7de70f0ac91437d8231e2880519090fc5143efb9ac7432c78303a5d7ce04f8e91ad78cfd SHA512 743cac75b1fa9f257f7b79c32211b061b29f359a97cf256ba8c3693eedbc186a43805d507d0e5726c49ef74f9777c68b3a204347d79058a0cc4f3891fce2fcc4
+DIST botocore-1.15.16.tar.gz 6173930 BLAKE2B 70e185faa9fa3f8537e38e4db8c263f5bfb0430d827e1093d41fdae8a16d6975071d3eec0eddde41d92044eebed92396d65f70eaf21a4ea2e6a1b464498c7f15 SHA512 574f0fc8cfa34e16b9933a7c7dd9fc9a95f713f8693507eac5598e73775def6df209b2883abf5a13e68327bf1e89508fce5d37074cd3a0173ab5cd1e35372409
DIST botocore-1.15.5.tar.gz 6146598 BLAKE2B 09b5b8dfd776bc13c0d1f52a61f80ae24a41daf1a14531e256273b1eab2cf824a42e60028eb42aabd19ab990369a9692172820b6a37cb0a9ee1275fe060466eb SHA512 34375b8585f4fa97c3a5672f03cdeb1961b6729d82f9706c04fd9f5ff1cc7bb33170ac147033bbc751c3c73ef558ba185b7e6526de0063190c14ec102901b56e
diff --git a/dev-python/botocore/botocore-1.15.16.ebuild b/dev-python/botocore/botocore-1.15.16.ebuild
new file mode 100644
index 000000000000..f9ce3c85acf8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.15.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}