summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-22 23:15:35 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-22 23:15:35 +0100
commitee7d2df3bacc99ee36f3bf9f1214d4d9c56d308b (patch)
tree03d6ce933100c21ac096e1a9afb8d8102c018684 /dev-python/botocore
parentapp-arch/rar: drop old (diff)
downloadgentoo-ee7d2df3bacc99ee36f3bf9f1214d4d9c56d308b.tar.gz
gentoo-ee7d2df3bacc99ee36f3bf9f1214d4d9c56d308b.tar.bz2
gentoo-ee7d2df3bacc99ee36f3bf9f1214d4d9c56d308b.zip
dev-python/botocore: bump to v1.13.44
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.13.44.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7cf8cc8e6f69..0224abe9947b 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,3 +10,4 @@ DIST botocore-1.13.19.tar.gz 5653940 BLAKE2B b7fa4678cb62bdc1c0db517e537c3c6a038
DIST botocore-1.13.2.tar.gz 5560942 BLAKE2B a46c72fc62bb776e4d462fea49d7010f45502c201d956ce5878fe9b8673cadf186b5c61e60bda5d666eb47454799fa53f40cf59d7f10246c79374132fc3d03e8 SHA512 ef48ae18c61c83b43ac435c9b9e3e7c69963c19cc79bb34c7541d5d823f952c022b1b7e4eb1dfa33dd9fe5c14c87f7cf72d0e9d17012984c9f10c06abe27d279
DIST botocore-1.13.28.tar.gz 5881818 BLAKE2B 9ec33e256a1dd09be0951e880947eaa9394e538823458859d6f44516b278a144337fcfac1cbdc6aa87babaa7c177aa936bbf3587ff7ff94a228b34f99557701e SHA512 3c6ffa5389639643d237c6945942add1aa21f40419a31fc8bdb06532505e7d5e273afd6616705fce1d46ce76e997b9c3a6854876549b26020f1ee8a019c93a2b
DIST botocore-1.13.36.tar.gz 6029078 BLAKE2B 83cccf74c368f9ee5292b8f880545582f220518491924d65991618a505649e795e89cae0f898c63e9b140afc4d2ff1a4861447e827d8a915e44412b7534ddbb8 SHA512 6b342a4a9c473a8c818b1de8fc799d746de9642b67d43d8da2e6eac8d4263b9300609359c22ea553c30dbe37ec64e8760934a5b21f8f25de71868cd88c4e1878
+DIST botocore-1.13.44.tar.gz 6063673 BLAKE2B fc13c068f1173789188ce0d6c7b51294bb4a1ff2a1ce4823e20481ba2ea7e30972161e6f3439a1047f135259c5f10fbe5755b9301682fca9a5c7c882b363386f SHA512 1720dd64bc245e66bbda1c9c7369f16f3870c6cb9f2908e6ffa5bc4c6c211acc5e922d45bee2c13dc44665e5b69738b920f15a02572631804a6625cbe82d331e
diff --git a/dev-python/botocore/botocore-1.13.44.ebuild b/dev-python/botocore/botocore-1.13.44.ebuild
new file mode 100644
index 000000000000..1b2106971f31
--- /dev/null
+++ b/dev-python/botocore/botocore-1.13.44.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}