summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-10 17:34:00 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-10 17:35:29 +0100
commitf36c7d35421628af7fc19cfaa130a45f25a59f53 (patch)
treeeb45236268d07af7a02fc4fa736c750f9b2860dc /dev-python/botocore
parentnet-mail/checkpassword: drop old EAPI (diff)
downloadgentoo-f36c7d35421628af7fc19cfaa130a45f25a59f53.tar.gz
gentoo-f36c7d35421628af7fc19cfaa130a45f25a59f53.tar.bz2
gentoo-f36c7d35421628af7fc19cfaa130a45f25a59f53.zip
dev-python/botocore: bump to v1.13.14
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.13.14.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4e3c5d72e700..cbf4f8a355e7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,4 +5,5 @@ DIST botocore-1.12.223.tar.gz 5892788 BLAKE2B 32a25636c7e3882e567daefeb0945863dd
DIST botocore-1.12.251.tar.gz 5936418 BLAKE2B a665d8a4c22bde4e5968b845e6df072a3ed2ce53561e007f2eaae144a91a77a32566c3c7f7a0158136b3e6d67aacffd5b77eed5fab51fe60fdfa29eb93e918ce SHA512 b29930367c602d40a7ce2386070dbaf83f34ea9321c7da40bf76ad7dae0587258fa2b3a058d17932d3e5fa22248c3ea5c838716fec5dce8da49e851b5c4f88d9
DIST botocore-1.12.4.tar.gz 4800384 BLAKE2B 121019d3c33872fdd874ddba36ecc8612a6354068ce7b759cbe7f35a9787e84c34d3a71ef3fdd2d721d3c3973a7600e4398cb7cd2a3ba698464c15137845bdf3 SHA512 8d196984f5623df403a8a23a9b7e7061e59c0ca56103f89d749d6ad7d92168ccae267f85312f2949cee322776d7948f1ecfda3d9d2783e8ba92fde7a178e8cac
DIST botocore-1.12.81.tar.gz 5383717 BLAKE2B 0bafd6038cf4a5d1fa4f0597024b09eca48ab95d071cccd09b1910ccf839719114166fab7d78bd2b30dec4b4993a0751d9504260636174df5f76f02495e79960 SHA512 d3be22af53a8c6dd55be3fa0b84a55cdce22d30d6e6f04b0bb69539b8107c86de6b5494079e3af40f9b5285ef10c21e69c85295e5cd7c6dc5ab5be91718a2ea9
+DIST botocore-1.13.14.tar.gz 5598238 BLAKE2B dda5dc707adc0b7b6239431f6230482650845d3e9049c963a873926ab1ef0e5e12cee2172cee79de886b726fd6cc8aa77ebbfb34757c64f9e644d9197a52e84c SHA512 a82724041d9e7ae5f2197ddfb922a1c0df99e1e8cbb47be4c18ab2a97b811fb8071dd512eb41e552563a3d97a640fbc7ec421d75dc51bd718339b061546f933e
DIST botocore-1.13.2.tar.gz 5560942 BLAKE2B a46c72fc62bb776e4d462fea49d7010f45502c201d956ce5878fe9b8673cadf186b5c61e60bda5d666eb47454799fa53f40cf59d7f10246c79374132fc3d03e8 SHA512 ef48ae18c61c83b43ac435c9b9e3e7c69963c19cc79bb34c7541d5d823f952c022b1b7e4eb1dfa33dd9fe5c14c87f7cf72d0e9d17012984c9f10c06abe27d279
diff --git a/dev-python/botocore/botocore-1.13.14.ebuild b/dev-python/botocore/botocore-1.13.14.ebuild
new file mode 100644
index 000000000000..f81c7d0b849a
--- /dev/null
+++ b/dev-python/botocore/botocore-1.13.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}