summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-10-22 19:47:54 +0200
committerSebastian Pipping <sping@gentoo.org>2016-10-22 21:49:05 +0200
commite407accc5f207a7c96c30938eca170c3b7e46031 (patch)
tree3802252a2124bb004857e2eb590ec47f0f0fb6da /dev-python/bottle/bottle-0.12.10.ebuild
parentdev-python/aldryn-search: version bump to 0.3.0 (diff)
downloadgentoo-e407accc5f207a7c96c30938eca170c3b7e46031.tar.gz
gentoo-e407accc5f207a7c96c30938eca170c3b7e46031.tar.bz2
gentoo-e407accc5f207a7c96c30938eca170c3b7e46031.zip
dev-python/bottle: 0.12.10
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/bottle/bottle-0.12.10.ebuild')
-rw-r--r--dev-python/bottle/bottle-0.12.10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/bottle/bottle-0.12.10.ebuild b/dev-python/bottle/bottle-0.12.10.ebuild
new file mode 100644
index 000000000000..1042e167fef0
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="https://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm ./test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # A few odd fails in the suite under pypy
+ # https://github.com/bottlepy/bottle/issues/714
+ "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}