summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-22 15:19:11 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-22 15:19:11 -0400
commitb53013b492820ef07067449b9a91182078b8652e (patch)
treeef74f3ceec4ae7aa32e6696a4a67dc1e8cf58a36 /dev-python/bottleneck/bottleneck-0.8.0.ebuild
parentdev-python/bottleneck: bump to 1.2.1 (diff)
downloadgentoo-b53013b492820ef07067449b9a91182078b8652e.tar.gz
gentoo-b53013b492820ef07067449b9a91182078b8652e.tar.bz2
gentoo-b53013b492820ef07067449b9a91182078b8652e.zip
dev-python/bottleneck: remove old
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/bottleneck/bottleneck-0.8.0.ebuild')
-rw-r--r--dev-python/bottleneck/bottleneck-0.8.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/bottleneck/bottleneck-0.8.0.ebuild b/dev-python/bottleneck/bottleneck-0.8.0.ebuild
deleted file mode 100644
index 80a55c122fb2..000000000000
--- a/dev-python/bottleneck/bottleneck-0.8.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-MY_PN="Bottleneck"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Fast NumPy array functions written in Cython"
-HOMEPAGE="https://pypi.org/project/Bottleneck/"
-SRC_URI="mirror://pypi/B/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"/${MY_P}
-
-python_prepare_all() {
- emake cfiles
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${BUILD_DIR}" || die
- ${PYTHON} -c "import bottleneck;bottleneck.test(extra_argv=['--verbosity=3'])" || die
-}