summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-03 23:53:26 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-04 01:47:10 +0100
commit19cf2f8406cee9fb692db479461d495d196bca12 (patch)
treebe3160225397912a748b82eaafdf58e3d6896b51 /dev-python/brython
parentapp-text/html-xml-utils: version bump. (diff)
downloadgentoo-19cf2f8406cee9fb692db479461d495d196bca12.tar.gz
gentoo-19cf2f8406cee9fb692db479461d495d196bca12.tar.bz2
gentoo-19cf2f8406cee9fb692db479461d495d196bca12.zip
dev-python/brython: version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/brython')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.2.9.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index c0de0c8dffdf..f1ae07aa7386 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,3 +1,4 @@
DIST brython-3.2.6.zip 9330416 SHA256 209f5ddd5165c083217c3146fbdf1dcbc26346f4e3366172c61e08d5af4a22e7 SHA512 307c914b5bbe30765187ff57c324a4ce575b28ea6b41f87e81b02309b1fae7d011603c006d9ab938af50657167de3d66b48de1a92363f76e225a0a3948d4e045 WHIRLPOOL f9a4bc892c2eb1737bb25486ec4c3dfb9615cb18191ac4e87f09316a2be4165236b4e578be374d493908a1d812417cdd7de7c9ab3aabd9eae257957af15c7099
DIST brython-3.2.7.zip 9087095 SHA256 83aeef2e68491eadf977c41f0d41fb50bf5c1436c0e2417be47011793d2cdf9e SHA512 e137d4f01ccd67307b1f4f93c09c3654d6bdae8d3d8f9cb9c38777be9c527b93326cdd518cced4df39832a263159cc0256fa25d0328d32248eb82ca62e1ec024 WHIRLPOOL e578698e783ef6d615942887d4cfcb49daf517503150a588a9aecee5ab247f251ed21fb67f713219bcb53ece3b5b8b0073638378213802924da5da8a1e27e1d0
DIST brython-3.2.8.zip 9165384 SHA256 6ae0ddb8b8b9529ceba4b9dbbcc2276eef787e4933bf4f94275cf0cf192eb96a SHA512 409d1338120479bfb0558e7f875f36d022e1a86ce2bbe8cb30ab10a4e2059f2e0ffa6fb7681ecddcf373bbc483a6c25ff44c647c1f38acc7afc14907506b793d WHIRLPOOL 8c411f0e22563799ccfffde707d70b2272aac0d6d40ef5f1d00889968caf8990b9ae6105db1d0c25226024a45027e24c4fd41081fe4ae1fad06d4683fea809e3
+DIST brython-3.2.9.zip 9430857 SHA256 a4eb0fd99312cb3d11f4d98f8dea0f633fc96ee99bf3e46c9ba02acd9f095072 SHA512 a68c4b88f4c3c2bdd8e713721eb87fe1af053097bf3f8fe0999a0088cb414831c797231eb335fcac3a3d6110059f7e1974a1642cd41fca48bf543fa7989cf850 WHIRLPOOL bca1ac9122a1a111ee5bf7c8f950a7f1c2a418b31c0eb487f3ed587f7278033ef58c9736b1cf208aa374e62a36fbbb9e7f4872eeb07030feb76a7249d2886513
diff --git a/dev-python/brython/brython-3.2.9.ebuild b/dev-python/brython/brython-3.2.9.ebuild
new file mode 100644
index 000000000000..feed5f4f8364
--- /dev/null
+++ b/dev-python/brython/brython-3.2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/python:*"
+
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}