summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-19 23:40:49 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-19 23:43:32 +0100
commitff55214f0690a6166c9fa4d9ac757b2d401e1e3f (patch)
tree923914955381eb9880efa84175aaf20fe30f173d /dev-python/brython
parentkde-plasma/khotkeys: Fix build with KF-5.31 (diff)
downloadgentoo-ff55214f0690a6166c9fa4d9ac757b2d401e1e3f.tar.gz
gentoo-ff55214f0690a6166c9fa4d9ac757b2d401e1e3f.tar.bz2
gentoo-ff55214f0690a6166c9fa4d9ac757b2d401e1e3f.zip
dev-python/brython: version bump.
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/brython')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.3.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index a3fdb137fc09..e2ffa939e6cc 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,3 +1,4 @@
DIST brython-3.2.8.zip 9165384 SHA256 6ae0ddb8b8b9529ceba4b9dbbcc2276eef787e4933bf4f94275cf0cf192eb96a SHA512 409d1338120479bfb0558e7f875f36d022e1a86ce2bbe8cb30ab10a4e2059f2e0ffa6fb7681ecddcf373bbc483a6c25ff44c647c1f38acc7afc14907506b793d WHIRLPOOL 8c411f0e22563799ccfffde707d70b2272aac0d6d40ef5f1d00889968caf8990b9ae6105db1d0c25226024a45027e24c4fd41081fe4ae1fad06d4683fea809e3
DIST brython-3.2.9.zip 9430857 SHA256 a4eb0fd99312cb3d11f4d98f8dea0f633fc96ee99bf3e46c9ba02acd9f095072 SHA512 a68c4b88f4c3c2bdd8e713721eb87fe1af053097bf3f8fe0999a0088cb414831c797231eb335fcac3a3d6110059f7e1974a1642cd41fca48bf543fa7989cf850 WHIRLPOOL bca1ac9122a1a111ee5bf7c8f950a7f1c2a418b31c0eb487f3ed587f7278033ef58c9736b1cf208aa374e62a36fbbb9e7f4872eeb07030feb76a7249d2886513
DIST brython-3.3.0.zip 9405649 SHA256 4b63b4758bbf08e865fcda647e064265ddc12a6d0cdb76489a614c73c28a8d02 SHA512 03b0dfcdd1be4a415423317d74fc0c941cdac5682a17a19ccf81d9b19058fda342d21397870a1a8e74a445155f7f736977278d21c38fb22251c8ed4a4489b194 WHIRLPOOL 5356a58b155b1783c9bc30c2e9d015660824002101fe6ab9fb183833b370a3aea71cc40ae4c67908f828e202a81968dfb9c4a77e825638f3f02439d56ed1a329
+DIST brython-3.3.1.zip 9420425 SHA256 f485004d20de86877b9008d0942b308ad2f52565bafc2a2c6968ec43dd336a72 SHA512 070573db3ef7cd571df32798564496f2036c375abb396785f2ad7fef321b028baa6f554642a6cb76a25e892b569d4c8ea6e4bc2251f8171b7721669d158470ec WHIRLPOOL a959cae1de4a6bbb4bc973861a14f3d4b976012a1f9853955163203ee9c1cc09178a7190a9289673c5c93fb5ad6adc994f776c1a56888586756ce1c2e51dc3fa
diff --git a/dev-python/brython/brython-3.3.1.ebuild b/dev-python/brython/brython-3.3.1.ebuild
new file mode 100644
index 000000000000..6f102b0f899e
--- /dev/null
+++ b/dev-python/brython/brython-3.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-lang/python:*"
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}