summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-03 23:23:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-15 01:21:27 +0200
commitc1ed105b1eeb213edbbd7405bfa13a0d89e48711 (patch)
tree93865cc3d3f885c9e47212cf63f8b956a760052f /dev-python/bsddb3
parentdev-python/billiard: Drop superfluous calls to python_is_python3 (diff)
downloadgentoo-c1ed105b1eeb213edbbd7405bfa13a0d89e48711.tar.gz
gentoo-c1ed105b1eeb213edbbd7405bfa13a0d89e48711.tar.bz2
gentoo-c1ed105b1eeb213edbbd7405bfa13a0d89e48711.zip
dev-python/bsddb3: Drop superfluous calls to python_is_python3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/bsddb3-6.2.7.ebuild13
1 files changed, 1 insertions, 12 deletions
diff --git a/dev-python/bsddb3/bsddb3-6.2.7.ebuild b/dev-python/bsddb3/bsddb3-6.2.7.ebuild
index b925dd3cd69d..47c88f81dcd2 100644
--- a/dev-python/bsddb3/bsddb3-6.2.7.ebuild
+++ b/dev-python/bsddb3/bsddb3-6.2.7.ebuild
@@ -63,17 +63,6 @@ python_configure_all() {
export YES_I_HAVE_THE_RIGHT_TO_USE_THIS_BERKELEY_DB_VERSION=1
}
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- distutils-r1_python_compile
-}
-
python_test() {
- if python_is_python3; then
- PYTHONPATH=Lib3 "${EPYTHON}" test3.py -v || die "Testing failed with ${EPYTHON}"
- else
- PYTHONPATH=Lib "${EPYTHON}" test.py -v || die "Testing failed with ${EPYTHON}"
- fi
+ PYTHONPATH=Lib3 "${EPYTHON}" test3.py -v || die "Testing failed with ${EPYTHON}"
}