summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-21 22:20:50 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-21 23:26:40 +0100
commit9542b6dff22071189b70d0b7551cd5366e41e366 (patch)
treebeb7ecced9fcc41ca4567f41285a187a36a1bc4e /dev-python/bz2file/bz2file-0.98.ebuild
parentdev-python/pylzma: Bump to 0.4.9, enable tests (diff)
downloadgentoo-9542b6dff22071189b70d0b7551cd5366e41e366.tar.gz
gentoo-9542b6dff22071189b70d0b7551cd5366e41e366.tar.bz2
gentoo-9542b6dff22071189b70d0b7551cd5366e41e366.zip
dev-python/bz2file: Bump to 0.98
Diffstat (limited to 'dev-python/bz2file/bz2file-0.98.ebuild')
-rw-r--r--dev-python/bz2file/bz2file-0.98.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/bz2file/bz2file-0.98.ebuild b/dev-python/bz2file/bz2file-0.98.ebuild
new file mode 100644
index 000000000000..7fcf93002fea
--- /dev/null
+++ b/dev-python/bz2file/bz2file-0.98.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+DESCRIPTION="Replacement for bz2.BZ2File with features from newest CPython"
+HOMEPAGE="https://pypi.python.org/pypi/bz2file https://github.com/nvawda/bz2file"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ "${PYTHON}" test_bz2file.py -v || die "Tests fail with ${EPYTHON}"
+}