summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-05 18:17:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-05 18:24:32 +0200
commitb1196d549dabf334b4e1476a59870ec3ba258a37 (patch)
treef16c75fbb3bcbdfe65a43e5f9732aa4bce80773c /dev-python/cairocffi
parentdev-python/xcffib: Port to py39 (diff)
downloadgentoo-b1196d549dabf334b4e1476a59870ec3ba258a37.tar.gz
gentoo-b1196d549dabf334b4e1476a59870ec3ba258a37.tar.bz2
gentoo-b1196d549dabf334b4e1476a59870ec3ba258a37.zip
dev-python/cairocffi: Port to py39, remove docs
Closes: https://bugs.gentoo.org/715060 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cairocffi')
-rw-r--r--dev-python/cairocffi/cairocffi-1.1.0.ebuild34
1 files changed, 7 insertions, 27 deletions
diff --git a/dev-python/cairocffi/cairocffi-1.1.0.ebuild b/dev-python/cairocffi/cairocffi-1.1.0.ebuild
index 457f63121118..29fbbca716f4 100644
--- a/dev-python/cairocffi/cairocffi-1.1.0.ebuild
+++ b/dev-python/cairocffi/cairocffi-1.1.0.ebuild
@@ -3,53 +3,33 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 virtualx
-MY_PN="${PN}"
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
HOMEPAGE="https://github.com/Kozea/cairocffi"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
RDEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ ' 'python*')
>=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
x11-libs/cairo:0=[X,xcb(+)]
x11-libs/gdk-pixbuf[jpeg]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
+distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${PN}-0.8.0-tests.patch
"${FILESDIR}"/${PN}-1.0.2-test-deps.patch
)
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
python_test() {
- virtx py.test -v --pyargs cairocffi
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
+ virtx pytest -vv --pyargs cairocffi
}