summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-01-21 02:20:48 -0800
committerZac Medico <zmedico@gentoo.org>2018-01-21 02:26:41 -0800
commit2c24e75337ab46c4b121709ab9fb5b3ab01b7e96 (patch)
treec3d85e9c6432f7f8704a400d36aae400f623516c /dev-python/case/case-1.5.2-r1.ebuild
parentmedia-libs/libdvdnav: Synced live ebuild. (diff)
downloadgentoo-2c24e75337ab46c4b121709ab9fb5b3ab01b7e96.tar.gz
gentoo-2c24e75337ab46c4b121709ab9fb5b3ab01b7e96.tar.bz2
gentoo-2c24e75337ab46c4b121709ab9fb5b3ab01b7e96.zip
dev-python/case: revbump to 1.5.2-r1 to add RDEPEND
If these deps are missing at runtime then the unit tests of consumers will attempt to download them from pypi, like the dev-python/vine-1.1.3 unit tests in bug 645214. Closes: https://bugs.gentoo.org/645214 Package-Manager: Portage-2.3.20, Repoman-2.3.6 RepoMan-Options: --force
Diffstat (limited to 'dev-python/case/case-1.5.2-r1.ebuild')
-rw-r--r--dev-python/case/case-1.5.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/case/case-1.5.2-r1.ebuild b/dev-python/case/case-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..2a0e878cf66d
--- /dev/null
+++ b/dev-python/case/case-1.5.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python unittest Utilities"
+HOMEPAGE="https://pypi.python.org/pypi/${PN} https://github.com/celery/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+RDEPEND=">=dev-python/nose-1.3.7[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"