summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:48:15 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:59:03 -0600
commit50251df99cab43bbbaeb6f751e92a2287c431e43 (patch)
tree15374b7554dff81d246ddb99be89f10f83eacf76 /dev-python/castellan/castellan-0.17.0.ebuild
parentdev-python/python-glanceclient: cleanup (diff)
downloadgentoo-50251df99cab43bbbaeb6f751e92a2287c431e43.tar.gz
gentoo-50251df99cab43bbbaeb6f751e92a2287c431e43.tar.bz2
gentoo-50251df99cab43bbbaeb6f751e92a2287c431e43.zip
dev-python/castellan: 0.17.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/castellan/castellan-0.17.0.ebuild')
-rw-r--r--dev-python/castellan/castellan-0.17.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/castellan/castellan-0.17.0.ebuild b/dev-python/castellan/castellan-0.17.0.ebuild
new file mode 100644
index 000000000000..8f408674d4b7
--- /dev/null
+++ b/dev-python/castellan/castellan-0.17.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.9[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+"