summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:06:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:06:25 -0500
commitd649a54a1b2db66ba2937ef6bafe47db610d78b9 (patch)
treefcff85e074fae3df309b426cbeb85d7ec67fe258 /dev-python/castellan
parentkde-misc/skanlite: Version bump 2.0 (diff)
downloadgentoo-d649a54a1b2db66ba2937ef6bafe47db610d78b9.tar.gz
gentoo-d649a54a1b2db66ba2937ef6bafe47db610d78b9.tar.bz2
gentoo-d649a54a1b2db66ba2937ef6bafe47db610d78b9.zip
dev-python/castellan: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/castellan')
-rw-r--r--dev-python/castellan/Manifest1
-rw-r--r--dev-python/castellan/castellan-0.4.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/castellan/Manifest b/dev-python/castellan/Manifest
index 7517e385d56d..3645801c8f9e 100644
--- a/dev-python/castellan/Manifest
+++ b/dev-python/castellan/Manifest
@@ -1 +1,2 @@
DIST castellan-0.2.1.tar.gz 34989 SHA256 d2f94c36b84e0ade1a64a8eb4d0081065838d6110931294fb0d013fc3159a9c6 SHA512 14bbf428988299ae3b80aaa53d79e09e8e1a0533203d056db3cdebe2cdd7e7a4af74517e0ac0c57f9ad845d12282cf12607936252591a894c1916d4fcca71ba5 WHIRLPOOL b61cb1986445635749db3d74aec7b2352ad086434b7eb7fcf617b00317d12d0ee2b8c7d0887f0eb23d73ef37e2ca8544d2862ee1836974b2847d0bddd49738d4
+DIST castellan-0.4.0.tar.gz 49026 SHA256 2ccefefc2036ed0d6c76d735fb70b813e2a02f7adb7fd57e0640d064dce1c883 SHA512 2ccb2a757810c6ec125dbb8832cd09f918f9fbf84836ff69c79872471c7e4e40bc8030e305336ad9821de7c3b93617d39917387a6ab8f68443fb09d3f74d4dd5 WHIRLPOOL 972ef43c96356b4dfd69a5716aa996c6b0ac4ab54a989f8e38e3036e63043a33148e0e475224cfc9c4d7e2e5f122af476553015fc840b6326f599bd472f2f936
diff --git a/dev-python/castellan/castellan-0.4.0.ebuild b/dev-python/castellan/castellan-0.4.0.ebuild
new file mode 100644
index 000000000000..78a246205540
--- /dev/null
+++ b/dev-python/castellan/castellan-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=" >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3
+ >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]"