summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-17 14:57:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-17 15:07:58 +0200
commit80e6c6832cac0fad58606dd7288ccc0f4dac240e (patch)
treedb62070d710540bce9a3a739463c8f99a26d3334 /dev-python/catkin_pkg/catkin_pkg-9999.ebuild
parentdev-python/catkin_pkg: Remove old (diff)
downloadgentoo-80e6c6832cac0fad58606dd7288ccc0f4dac240e.tar.gz
gentoo-80e6c6832cac0fad58606dd7288ccc0f4dac240e.tar.bz2
gentoo-80e6c6832cac0fad58606dd7288ccc0f4dac240e.zip
dev-python/catkin_pkg: eapi update, bump to 0.4.8
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-9999.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 46f2913d41f1..f4dc76b3fa34 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
@@ -32,13 +32,16 @@ RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
)
"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
RDEPEND="${RDEPEND}
!<dev-util/catkin-0.7.14"
PATCHES=(