summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-18 18:55:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-21 15:47:07 +0200
commit04db859ba4e4f6202a5a5326edc9b59d42894574 (patch)
treebe336674cbd1dce158f2ec2476957b83eb5af381 /dev-python/catkin_pkg
parentdev-db/mariadb-connector-c: enable ICONV support (diff)
downloadgentoo-04db859ba4e4f6202a5a5326edc9b59d42894574.tar.gz
gentoo-04db859ba4e4f6202a5a5326edc9b59d42894574.tar.bz2
gentoo-04db859ba4e4f6202a5a5326edc9b59d42894574.zip
dev-python/catkin_pkg: improve catkin prefix patch not to require cmake
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.22-r1.ebuild (renamed from dev-python/catkin_pkg/catkin_pkg-0.4.22.ebuild)0
-rw-r--r--dev-python/catkin_pkg/files/catkin_prefix2.patch11
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.22.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.22-r1.ebuild
index 53b5bb90f674..53b5bb90f674 100644
--- a/dev-python/catkin_pkg/catkin_pkg-0.4.22.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-0.4.22-r1.ebuild
diff --git a/dev-python/catkin_pkg/files/catkin_prefix2.patch b/dev-python/catkin_pkg/files/catkin_prefix2.patch
index 761894e83b1c..064ad1ca65f2 100644
--- a/dev-python/catkin_pkg/files/catkin_prefix2.patch
+++ b/dev-python/catkin_pkg/files/catkin_prefix2.patch
@@ -2,10 +2,10 @@ Allow CATKIN_PREFIX_PATH to work as CMAKE_PREFIX_PATH:
When building with SYSROOT!=/, CMAKE_PREFIX_PATH is the same as with SYSROOT=/
but we need to find packages in SYSROOT.
-Index: catkin_pkg-0.4.6/src/catkin_pkg/workspaces.py
+Index: catkin_pkg-0.4.22/src/catkin_pkg/workspaces.py
===================================================================
---- catkin_pkg-0.4.6.orig/src/catkin_pkg/workspaces.py
-+++ catkin_pkg-0.4.6/src/catkin_pkg/workspaces.py
+--- catkin_pkg-0.4.22.orig/src/catkin_pkg/workspaces.py
++++ catkin_pkg-0.4.22/src/catkin_pkg/workspaces.py
@@ -41,16 +41,17 @@ CATKIN_WORKSPACE_MARKER_FILE = '.catkin_
def get_spaces(paths=None):
@@ -20,10 +20,11 @@ Index: catkin_pkg-0.4.6/src/catkin_pkg/workspaces.py
if paths is None:
- if 'CMAKE_PREFIX_PATH' not in os.environ:
- raise RuntimeError('Neither the environment variable CMAKE_PREFIX_PATH is set nor was a list of paths passed.')
+- paths = os.environ['CMAKE_PREFIX_PATH'].split(os.pathsep) if os.environ['CMAKE_PREFIX_PATH'] else []
+ if 'CMAKE_PREFIX_PATH' not in os.environ and 'CATKIN_PREFIX_PATH' not in os.environ:
+ raise RuntimeError('None of the environment variables CMAKE_PREFIX_PATH or CATKIN_PREFIX_PATH are set nor was a list of paths passed.')
- paths = os.environ['CMAKE_PREFIX_PATH'].split(os.pathsep) if os.environ['CMAKE_PREFIX_PATH'] else []
-+ paths += os.environ['CATKIN_PREFIX_PATH'].split(os.pathsep) if os.environ['CATKIN_PREFIX_PATH'] else []
++ paths = os.environ['CMAKE_PREFIX_PATH'].split(os.pathsep) if os.environ.get('CMAKE_PREFIX_PATH') else []
++ paths += os.environ['CATKIN_PREFIX_PATH'].split(os.pathsep) if os.environ.get('CATKIN_PREFIX_PATH') else []
spaces = []
for path in paths: