summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-15 08:02:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 08:25:26 +0200
commit22d803245bc35305dde45a1873ffc5d352ed5fac (patch)
tree34e726a7b66c1aebcfef366a32fd5627d51029dc /dev-python/catkin_pkg
parentdev-ml/ppx_variants_conv: convert to opam.eclass (diff)
downloadgentoo-22d803245bc35305dde45a1873ffc5d352ed5fac.tar.gz
gentoo-22d803245bc35305dde45a1873ffc5d352ed5fac.tar.bz2
gentoo-22d803245bc35305dde45a1873ffc5d352ed5fac.zip
dev-python/catkin_pkg: bump to 0.3.6 and update infinite loop patch
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.3.6.ebuild46
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild2
-rw-r--r--dev-python/catkin_pkg/files/infinite_loop2.patch27
4 files changed, 75 insertions, 1 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index 6238f24ae9d0..1e1b7e22a3b8 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1,2 +1,3 @@
DIST catkin_pkg-0.3.4-gh.tar.gz 47286 SHA256 e57164c46c20a2de338112beab65095717fa459526e42c37390b392a1480d7ce SHA512 857ed23534a8fd4a3bcfeac5173041b71e57566606f206e588caf76dfbfbb49d9cdd938345979a63c79069a73a087bf8371154650c3694768ea0f53b6c80ba06 WHIRLPOOL 35c08a08f049ace703ea20b1c80a2e47278acc131968825aaee9cd21bb1237d24058fc69883106e318038d7c0c7922b47755276a4656d9667b114e989335881a
DIST catkin_pkg-0.3.5-gh.tar.gz 47325 SHA256 bc9f45bdc36ec251d04049fff6501c13e16fbe2913b1abd211cecf9b6499477f SHA512 21c22efc23f80982fbda97e65cde9e7609733f4fabb53716c5693e44d7f01a09bfede7e5b628b4b399a2fb5f01113e5d259cef5d0df5eb702dc114d65b988683 WHIRLPOOL dfbf1e7a85ecd39285c95ee4d51b2dbe986e935e2d0e127c3ade1fd9bc274c4d6cde1eb72131f129e4592adb841cb765f91e29231ae458a843c4b9515d0b0459
+DIST catkin_pkg-0.3.6-gh.tar.gz 47637 SHA256 b05797352a89986a6c637ef33685a8cd004a8e5138b553f42a82065bc02f808b SHA512 191ed93271c9e592040110c92a572570fa8dec328ae3203dfea9e1fb6a1cb906350c436d3a9416d6826e57a1d59ef42200797d6a5bdc390aa77d352f716e0cc8 WHIRLPOOL 83f73ddaad17b5cfef4945a4d0c900855586877c47962b903e68f821772f4281f7658d82c4adfdf8067889e82f1264d843f1c4f336876ac8afa1bdfe48edeb37
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.3.6.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.3.6.ebuild
new file mode 100644
index 000000000000..0967bd6ff8e6
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.3.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=(
+ "${FILESDIR}/catkin_prefix.patch"
+ "${FILESDIR}/argparse.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop2.patch"
+)
+
+python_test() {
+ nosetests -s --tests test || die
+}
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 28e56139aea2..0967bd6ff8e6 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -38,7 +38,7 @@ PATCHES=(
"${FILESDIR}/catkin_prefix.patch"
"${FILESDIR}/argparse.patch"
"${FILESDIR}/ros_packages.patch"
- "${FILESDIR}/infinite_loop.patch"
+ "${FILESDIR}/infinite_loop2.patch"
)
python_test() {
diff --git a/dev-python/catkin_pkg/files/infinite_loop2.patch b/dev-python/catkin_pkg/files/infinite_loop2.patch
new file mode 100644
index 000000000000..7c5edba2b50c
--- /dev/null
+++ b/dev-python/catkin_pkg/files/infinite_loop2.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/show_bug.cgi?id=612860
+By Tim Rakowski
+We os.walk /usr with followlinks=True, but at least nodejs contains a "recursive" link in /usr/include/node
+
+Index: catkin_pkg-0.3.6/src/catkin_pkg/packages.py
+===================================================================
+--- catkin_pkg-0.3.6.orig/src/catkin_pkg/packages.py
++++ catkin_pkg-0.3.6/src/catkin_pkg/packages.py
+@@ -56,7 +56,9 @@ def find_package_paths(basepath, exclude
+ """
+ paths = []
+ real_exclude_paths = [os.path.realpath(p) for p in exclude_paths] if exclude_paths is not None else []
++ visited = set()
+ for dirpath, dirnames, filenames in os.walk(basepath, followlinks=True):
++ visited.add(dirpath)
+ if 'CATKIN_IGNORE' in filenames or \
+ os.path.realpath(dirpath) in real_exclude_paths or \
+ (exclude_subspaces and '.catkin' in filenames):
+@@ -67,7 +69,7 @@ def find_package_paths(basepath, exclude
+ del dirnames[:]
+ continue
+ # filter out hidden directories in-place
+- dirnames[:] = [d for d in dirnames if not d.startswith('.')]
++ dirnames[:] = [d for d in dirnames if not d.startswith('.') and not os.path.realpath(os.path.join(dirpath, d)) in visited]
+ return paths
+
+