summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 09:22:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:48 +0100
commit25e32ee384088923b56e78198e9dd216637fae59 (patch)
treeacd60fd7d2a8b6c21d97937830f82547446fc610 /dev-python/catkin_pkg
parentdev-ros/rqt_gui: Add python 3.4/3.5 support (diff)
downloadgentoo-25e32ee384088923b56e78198e9dd216637fae59.tar.gz
gentoo-25e32ee384088923b56e78198e9dd216637fae59.tar.bz2
gentoo-25e32ee384088923b56e78198e9dd216637fae59.zip
dev-python/catkin_pkg: Allow having package.xml in ros_packages subdir without triggering duplicate.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.3.1-r2.ebuild42
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild9
-rw-r--r--dev-python/catkin_pkg/files/ros_packages.patch13
3 files changed, 56 insertions, 8 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.3.1-r2.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..e258fe5491b9
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.3.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" "${FILESDIR}/ros_packages.patch" )
+
+python_test() {
+ nosetests -s --tests test || die
+}
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 57cbb8ced996..e258fe5491b9 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -35,15 +35,8 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" "${FILESDIR}/ros_packages.patch" )
python_test() {
nosetests -s --tests test || die
}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Avoid recursing in the whole hierarchy
- dodir /usr/
- touch "${ED}/usr/CATKIN_IGNORE"
-}
diff --git a/dev-python/catkin_pkg/files/ros_packages.patch b/dev-python/catkin_pkg/files/ros_packages.patch
new file mode 100644
index 000000000000..6c9855d627c9
--- /dev/null
+++ b/dev-python/catkin_pkg/files/ros_packages.patch
@@ -0,0 +1,13 @@
+Index: catkin_pkg-0.3.1/src/catkin_pkg/packages.py
+===================================================================
+--- catkin_pkg-0.3.1.orig/src/catkin_pkg/packages.py
++++ catkin_pkg-0.3.1/src/catkin_pkg/packages.py
+@@ -59,7 +59,7 @@ def find_package_paths(basepath, exclude
+ del dirnames[:]
+ continue
+ elif PACKAGE_MANIFEST_FILENAME in filenames:
+- paths.append(os.path.relpath(dirpath, basepath))
++ paths.append(os.path.relpath(dirpath.replace('ros_packages/',''), basepath))
+ del dirnames[:]
+ continue
+ for dirname in dirnames: