summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-27 18:10:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:01:30 +0200
commit7d7fb38383c569252880d46938a01d09b7537d9a (patch)
tree84142c0ee112b35dae013d2bcfe2f5ac959394e9 /dev-python/catkin_pkg
parentdev-python/catkin_pkg: Remove old (diff)
downloadgentoo-7d7fb38383c569252880d46938a01d09b7537d9a.tar.gz
gentoo-7d7fb38383c569252880d46938a01d09b7537d9a.tar.bz2
gentoo-7d7fb38383c569252880d46938a01d09b7537d9a.zip
dev-python/catkin_pkg: bump to 0.4.13
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.13.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index ca86634745e9..fdacd46c857c 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1 +1,2 @@
DIST catkin_pkg-0.4.12-gh.tar.gz 61535 BLAKE2B 9b1a60cfc6bfda6e0f126f062cf62636df162577d693aaa07c4e7433f74383686224c31e0d567a95de20e2643c39f84781be3f82b39d9dfbbd1aed0dd397587e SHA512 227a6f07a46ab62d51f408a8aa08d57199a8f4d7c954421bf9a605fce3a0dc447c9379987bcacbed3bce139f00e95bd565286a530b7177acfc29a172da30f7dd
+DIST catkin_pkg-0.4.13-gh.tar.gz 61790 BLAKE2B b879b6e71c84863fdcbca1023dd5850a226c850e47348a5ce3cfa846bd4dfb7fe0fa2c406003b4d1a0ae7ab97e57a983a499c3a27851d3101c928765c9620cdf SHA512 b971019fe2f8e66639d271ce3a7933368a4af7658d143cb042a315492926a4b0c3593dc9f784ea75150aa048266219fe80f2a104adc6d361a6725d4b24aef330
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.13.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.13.ebuild
new file mode 100644
index 000000000000..d24c376aa411
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.4.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${RDEPEND}
+ !<dev-util/catkin-0.7.14"
+PATCHES=(
+ "${FILESDIR}/catkin_prefix2.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop3.patch"
+)
+
+python_test() {
+ nosetests -s --tests test || die
+}