summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-16 23:15:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-16 23:15:38 +0200
commit82b4d6250eab5e0350069bc76cf893730bfe5c81 (patch)
tree2bb778db8c39ef83af8fa8d0b378d09d148e2180 /dev-python/catkin_pkg
parentnet-misc/freerdp: fix build with ffmpeg git master. (diff)
downloadgentoo-82b4d6250eab5e0350069bc76cf893730bfe5c81.tar.gz
gentoo-82b4d6250eab5e0350069bc76cf893730bfe5c81.tar.bz2
gentoo-82b4d6250eab5e0350069bc76cf893730bfe5c81.zip
dev-python/catkin_pkg: Initial import. Ebuild by me.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild51
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild51
-rw-r--r--dev-python/catkin_pkg/files/catkin_prefix.patch28
-rw-r--r--dev-python/catkin_pkg/metadata.xml5
5 files changed, 136 insertions, 0 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
new file mode 100644
index 000000000000..733a2207e3ed
--- /dev/null
+++ b/dev-python/catkin_pkg/Manifest
@@ -0,0 +1 @@
+DIST catkin_pkg-0.2.10.tar.gz 44290 SHA256 df4a5e81dbcb42530cb7ccb4007e352f00ee4059de801f868e79949151e96403 SHA512 fe3fb8297319d410c4aa3f86c52ede5eabae4f51e70181b7ee2c6c4db9a576466d9d39970d410c95dd24900c6d9287cf64185aa267891bdb884b37d397807f7e WHIRLPOOL eac3196a9b00938eedb64710683951a3ca7d1d61110aeea5f82b3a863055e25861a8c61b89617d26a68f42a2573630c63e91423bff0e11c86b4f07076090d418
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
new file mode 100644
index 000000000000..b5bb86f49806
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="
+ http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ http://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+
+python_test() {
+ nosetests -s --tests test || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Avoid recursing in the whole hierarchy
+ dodir /usr/
+ touch "${ED}/usr/CATKIN_IGNORE"
+}
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
new file mode 100644
index 000000000000..b5bb86f49806
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="
+ http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ http://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+
+python_test() {
+ nosetests -s --tests test || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Avoid recursing in the whole hierarchy
+ dodir /usr/
+ touch "${ED}/usr/CATKIN_IGNORE"
+}
diff --git a/dev-python/catkin_pkg/files/catkin_prefix.patch b/dev-python/catkin_pkg/files/catkin_prefix.patch
new file mode 100644
index 000000000000..c5f40db51cd1
--- /dev/null
+++ b/dev-python/catkin_pkg/files/catkin_prefix.patch
@@ -0,0 +1,28 @@
+Allow CATKIN_PREFIX_PATH to work as CMAKE_PREFIX_PATH:
+When building with SYSROOT!=/, CMAKE_PREFIX_PATH is the same as with SYSROOT=/
+but we need to find packages in SYSROOT.
+
+Index: catkin_pkg-0.2.8/src/catkin_pkg/workspaces.py
+===================================================================
+--- catkin_pkg-0.2.8.orig/src/catkin_pkg/workspaces.py
++++ catkin_pkg-0.2.8/src/catkin_pkg/workspaces.py
+@@ -42,15 +42,16 @@ CATKIN_WORKSPACE_MARKER_FILE = '.catkin_
+
+ def get_spaces(paths=None):
+ """
+- Return a list of spaces based on the CMAKE_PREFIX_PATH or passed in list of workspaces.
++ Return a list of spaces based on the CMAKE_PREFIX_PATH/CATKIN_PREFIX_PATH or passed in list of workspaces.
+ It resolves the source space for each devel space and ignores non-catkin paths.
+ :param paths_to_order: list of paths
+ :param prefix_paths: list of prefixes, must not end with '/'
+ """
+ if paths is None:
+- if 'CMAKE_PREFIX_PATH' not in os.environ:
+- raise RuntimeError('Neither the environment variable CMAKE_PREFIX_PATH is set nor was a list of paths passed.')
++ if 'CMAKE_PREFIX_PATH' not in os.environ and 'CATKIN_PREFIX_PATH' not in os.environ :
++ raise RuntimeError('None of the environment variables CMAKE_PREFIX_PATH or CATKIN_PREFIX_PATH are set nor was a list of paths passed.')
+ paths = os.environ['CMAKE_PREFIX_PATH'].split(os.pathsep) if os.environ['CMAKE_PREFIX_PATH'] else []
++ paths += os.environ['CATKIN_PREFIX_PATH'].split(os.pathsep) if os.environ['CATKIN_PREFIX_PATH'] else []
+
+ spaces = []
+ for path in paths:
diff --git a/dev-python/catkin_pkg/metadata.xml b/dev-python/catkin_pkg/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-python/catkin_pkg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>