summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-07 20:47:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-08 16:19:03 +0200
commitcb4986b469652eb9f67cf744d807514cdd5b8a8d (patch)
tree55d746716ba68005cdea6bd50d1e4f842d3850fa /dev-python/catkin_pkg
parentdev-python/catkin_pkg: remove old (diff)
downloadgentoo-cb4986b469652eb9f67cf744d807514cdd5b8a8d.tar.gz
gentoo-cb4986b469652eb9f67cf744d807514cdd5b8a8d.tar.bz2
gentoo-cb4986b469652eb9f67cf744d807514cdd5b8a8d.zip
dev-python/catkin_pkg: bump to 0.3.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.3.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index 6d2110ea8900..6238f24ae9d0 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1 +1,2 @@
DIST catkin_pkg-0.3.4-gh.tar.gz 47286 SHA256 e57164c46c20a2de338112beab65095717fa459526e42c37390b392a1480d7ce SHA512 857ed23534a8fd4a3bcfeac5173041b71e57566606f206e588caf76dfbfbb49d9cdd938345979a63c79069a73a087bf8371154650c3694768ea0f53b6c80ba06 WHIRLPOOL 35c08a08f049ace703ea20b1c80a2e47278acc131968825aaee9cd21bb1237d24058fc69883106e318038d7c0c7922b47755276a4656d9667b114e989335881a
+DIST catkin_pkg-0.3.5-gh.tar.gz 47325 SHA256 bc9f45bdc36ec251d04049fff6501c13e16fbe2913b1abd211cecf9b6499477f SHA512 21c22efc23f80982fbda97e65cde9e7609733f4fabb53716c5693e44d7f01a09bfede7e5b628b4b399a2fb5f01113e5d259cef5d0df5eb702dc114d65b988683 WHIRLPOOL dfbf1e7a85ecd39285c95ee4d51b2dbe986e935e2d0e127c3ade1fd9bc274c4d6cde1eb72131f129e4592adb841cb765f91e29231ae458a843c4b9515d0b0459
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.3.5.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.3.5.ebuild
new file mode 100644
index 000000000000..28e56139aea2
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=(
+ "${FILESDIR}/catkin_prefix.patch"
+ "${FILESDIR}/argparse.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop.patch"
+)
+
+python_test() {
+ nosetests -s --tests test || die
+}