summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-25 17:09:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-25 17:48:47 +0200
commitd85a8af5ad02e58a830ba367c18ab2151de692a9 (patch)
treeeca4ea3942ed4d47f1800beadba911ac072f4f40 /dev-python/catkin_pkg
parentdev-python/os-vif: bup 1.4.1 (diff)
downloadgentoo-d85a8af5ad02e58a830ba367c18ab2151de692a9.tar.gz
gentoo-d85a8af5ad02e58a830ba367c18ab2151de692a9.tar.bz2
gentoo-d85a8af5ad02e58a830ba367c18ab2151de692a9.zip
dev-python/catkin_pkg: bump to 0.3.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.3.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index 7a519a840b4f..245b5000fe30 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1 +1,2 @@
DIST catkin_pkg-0.3.1-gh.tar.gz 46399 SHA256 3bfd1973c04db96f181ba2eb46a5eaf14620bb8db7aebc7ec8f2135c65a9d584 SHA512 be4e825ee45a68de3a3cb8eed337649a2f9b117054e24238cf4909fd11900698bdc59812e02e90c01fb3148d12713751e1afbea24531965eeb3fcbd2c36b014c WHIRLPOOL 433749f306e3b02dc2b87d5930423ed174ea133352caab8bb034295da6b9a9471b4f187d21784aebc130a56a0d4849565c2e0925649858615166bae7e0260249
+DIST catkin_pkg-0.3.3-gh.tar.gz 47229 SHA256 83da42ca2ffa13b17882bafe7ea62948a238b5a5e52ff108946d793980950acb SHA512 3dd13105577ceff1b83a8c4c1e6f2cb6e235fd8a44b06e7b80e8b5c929f851a3c907b94985f8d392c776c5ef840eed84c1d770cb991863edcdc4f6cca8c9a3e5 WHIRLPOOL 6d12ac1432642fe9c5f1f323879bbf5531f93c542104a5a34334fc3ce7ad09def179977385d53a2b5e65449020a5082c27bcc4725997b194b7b7f4c2e60a7a9d
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.3.3.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.3.3.ebuild
new file mode 100644
index 000000000000..28e56139aea2
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.3.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=(
+ "${FILESDIR}/catkin_prefix.patch"
+ "${FILESDIR}/argparse.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop.patch"
+)
+
+python_test() {
+ nosetests -s --tests test || die
+}