summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-16 05:12:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-16 05:31:42 +0100
commite7135ebb9b7ff1eb30386794ae563b5cbc415bd5 (patch)
tree089c6dc92c6fa1819ce968ef091b11c2a3cad7e7 /dev-python/catkin_pkg
parentdev-ros/std_msgs: bump to 0.5.11 (diff)
downloadgentoo-e7135ebb9b7ff1eb30386794ae563b5cbc415bd5.tar.gz
gentoo-e7135ebb9b7ff1eb30386794ae563b5cbc415bd5.tar.bz2
gentoo-e7135ebb9b7ff1eb30386794ae563b5cbc415bd5.zip
dev-python/catkin_pkg: Remove argparse dep from setup.py
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild (renamed from dev-python/catkin_pkg/catkin_pkg-0.3.1.ebuild)2
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild2
-rw-r--r--dev-python/catkin_pkg/files/argparse.patch12
3 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.3.1.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild
index fbc5d3f2d01c..ce8fd6d9c5b6 100644
--- a/dev-python/catkin_pkg/catkin_pkg-0.3.1.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-0.3.1-r1.ebuild
@@ -37,7 +37,7 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
python_test() {
nosetests -s --tests test || die
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index fbc5d3f2d01c..ce8fd6d9c5b6 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -37,7 +37,7 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
python_test() {
nosetests -s --tests test || die
diff --git a/dev-python/catkin_pkg/files/argparse.patch b/dev-python/catkin_pkg/files/argparse.patch
new file mode 100644
index 000000000000..f39df4a40565
--- /dev/null
+++ b/dev-python/catkin_pkg/files/argparse.patch
@@ -0,0 +1,12 @@
+Index: catkin_pkg-0.3.1/setup.py
+===================================================================
+--- catkin_pkg-0.3.1.orig/setup.py
++++ catkin_pkg-0.3.1/setup.py
+@@ -31,7 +31,6 @@ kwargs = {
+ 'long_description': 'Library for retrieving information about catkin packages.',
+ 'license': 'BSD',
+ 'install_requires': [
+- 'argparse',
+ 'docutils',
+ 'python-dateutil'
+ ],