summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 21:26:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 21:55:00 +0100
commitfce3ac1c95d722c2adb9098a7785eb9c10bb5d5c (patch)
tree5906efde4b4b05339da1a6082398deeed3d72239 /dev-python/cattrs
parentdev-python/asyncstdlib: Switch to PEP 517 build (diff)
downloadgentoo-fce3ac1c95d722c2adb9098a7785eb9c10bb5d5c.tar.gz
gentoo-fce3ac1c95d722c2adb9098a7785eb9c10bb5d5c.tar.bz2
gentoo-fce3ac1c95d722c2adb9098a7785eb9c10bb5d5c.zip
dev-python/cattrs: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cattrs')
-rw-r--r--dev-python/cattrs/cattrs-1.10.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cattrs/cattrs-1.10.0-r1.ebuild b/dev-python/cattrs/cattrs-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..6472f2331420
--- /dev/null
+++ b/dev-python/cattrs/cattrs-1.10.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Composable complex class support for attrs and dataclasses"
+HOMEPAGE="
+ https://pypi.org/project/cattrs/
+ https://github.com/python-attrs/cattrs/"
+SRC_URI="
+ https://github.com/python-attrs/cattrs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/immutables[${PYTHON_USEDEP}]
+ )"
+# test_preconf:
+# dev-python/bson[${PYTHON_USEDEP}]
+# dev-python/msgpack[${PYTHON_USEDEP}]
+# dev-python/orjson[${PYTHON_USEDEP}]
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/tomlkit[${PYTHON_USEDEP}]
+# dev-python/ujson[${PYTHON_USEDEP}]
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--benchmark.*::' \
+ -e '/addopts/d' \
+ -i pyproject.toml || die
+ # backport pyproject.toml fix (50ba769c8349f5891b157d2bb7f06602822ac0a3)
+ sed -e 's:group.dev.dependencies:dev-dependencies:' \
+ -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # unpackaged deps, see above
+ epytest tests --ignore tests/test_preconf.py
+}