summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-18 09:40:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-18 10:48:24 +0200
commit8ac13df033f1edfea9896b7aef86d7485e1dd811 (patch)
tree8120cdc75819216e0db40268c4be530b78f69b99 /dev-python/cbor2
parentdev-python/zconfig: Add python@ as co-maint. (diff)
downloadgentoo-8ac13df033f1edfea9896b7aef86d7485e1dd811.tar.gz
gentoo-8ac13df033f1edfea9896b7aef86d7485e1dd811.tar.bz2
gentoo-8ac13df033f1edfea9896b7aef86d7485e1dd811.zip
dev-python/cbor2: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cbor2')
-rw-r--r--dev-python/cbor2/Manifest1
-rw-r--r--dev-python/cbor2/cbor2-5.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cbor2/Manifest b/dev-python/cbor2/Manifest
index f37b56c16bd2..6685277d1ba8 100644
--- a/dev-python/cbor2/Manifest
+++ b/dev-python/cbor2/Manifest
@@ -1 +1,2 @@
DIST cbor2-5.2.0.tar.gz 81467 BLAKE2B ac35cf682f15eba2c2bff81f562fe2f22906ab8da39c04cbf65f403eeacb5e640e200b15a8cca0d7eede1d0106cd8674640b3093d166a4414a2d42452a374322 SHA512 101aed37c3921ace2f4a5fbb9964ddd2ec2ffcd23fb1a9f838b2f8925f17ffaf5eb39a40b5426e176f0c97a2ba1d3a045e96ceb53312b283101900eddacc6af4
+DIST cbor2-5.3.0.tar.gz 81162 BLAKE2B 41bb0f74998260e2612dbd1990970554b906eaca40e52c21fd90d026ce0aad706830b98f10a226bdc23b819d3f1c52f93f25892a1de04f2a673b4d150a5c47fa SHA512 05eacace46c4b2f7025f12613ae6a755aa7fab14f15d0131d4d856ec5c37bea547d3c4a8afdde28c8653139be741f47351de5460df7dd3ec662325c8d1e2f3fd
diff --git a/dev-python/cbor2/cbor2-5.3.0.ebuild b/dev-python/cbor2/cbor2-5.3.0.ebuild
new file mode 100644
index 000000000000..36bd7a9475e0
--- /dev/null
+++ b/dev-python/cbor2/cbor2-5.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -e "s/pytest-cov//" \
+ -e "s/--cov //" \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local deselect=()
+
+ if use arm || use x86; then
+ # https://github.com/agronholm/cbor2/issues/99
+ deselect+=(
+ tests/test_decoder.py::test_huge_truncated_bytes
+ tests/test_decoder.py::test_huge_truncated_string
+ )
+ fi
+
+ epytest ${deselect[@]/#/--deselect }
+}