summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-28 14:07:22 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-28 14:07:24 +0100
commit2453deec4be2ac6c256f1d1a1c8d6c2d3aef2788 (patch)
tree4af072e30e274daed425a736bda22ac47d450f4e /dev-python/certifi
parentdev-python/hypothesis: Bump to 4.47.5 (diff)
downloadgentoo-2453deec4be2ac6c256f1d1a1c8d6c2d3aef2788.tar.gz
gentoo-2453deec4be2ac6c256f1d1a1c8d6c2d3aef2788.tar.bz2
gentoo-2453deec4be2ac6c256f1d1a1c8d6c2d3aef2788.zip
dev-python/certifi: Bump to 2019.11.28
No changes relevant to Gentoo, just bundled certificate update. Bumping so that we don't end up having outdated package false positives. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/certifi')
-rw-r--r--dev-python/certifi/Manifest1
-rw-r--r--dev-python/certifi/certifi-2019.11.28.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
index 634cc48cb7ce..00b207456084 100644
--- a/dev-python/certifi/Manifest
+++ b/dev-python/certifi/Manifest
@@ -1,3 +1,4 @@
DIST certifi-2018.4.16.tar.gz 149967 BLAKE2B 4a69ec495266d54032dfabc9c17d0b1e78ad1467214f9f981feb4fae279c1f4b5f0bc3f7a643c2229b17d19e32c1ea894dc16d73b036a0b32f17faa9ac55615c SHA512 96369b318df9592ed4ff48d79ae695f89d27d85e8f5de72548fccb19ac15b83a33fb8bc096a3092d7a7f5b201af08805576888418c7927cf48b892df56464682
+DIST certifi-2019.11.28.tar.gz 156407 BLAKE2B 61fdee083aa1f5467bb4a6a65c9cdff2eb9e88261b4702f9d03b53abebb9f9815499a0cbcb53e983e81d5c54ed40e2ff7b351c19c90b2340373414e7e8afaea6 SHA512 6821444f02db0d9d03ab1891731178af1d7858df3c729f079147a9c588cf97a456e050da3421a0d2a3559145610826669034a8d46cd50b7c76e90249db1b09ad
DIST certifi-2019.6.16.tar.gz 156721 BLAKE2B 3990a9c122dbaf554f4482ad97192efa66f1cf54e83bd4ee67248bbea8797dc4da38ab537230a8263a491a2a2115528138965480ef4da6d6cba9ac2af5bff830 SHA512 4641626bc5073cd0b3a520855ddef1007dcb42933baa7a3469856f936e725581042bcbd5b67e984ba9748e7faa62b9125cba7dc160dcc5db2eafe46461a29f5e
DIST certifi-2019.9.11.tar.gz 154855 BLAKE2B 1a2e39b44e2285bcf2dfc0104873fc2c5004c54b346a27beebffa28894c22ba77b7ba0b17131e686846be14c2200ea0fba89f8b465f4c61139122d88d6d1ebf6 SHA512 aab5734bf65cbad12772bb120153b0325a5c3226339e0a03fdf4c3413303feb930b6d53d1d9dab93bd4f3cf00d2bfbe86419c4c462570340f1a4aa143a31373c
diff --git a/dev-python/certifi/certifi-2019.11.28.ebuild b/dev-python/certifi/certifi-2019.11.28.ebuild
new file mode 100644
index 000000000000..ba409ef85575
--- /dev/null
+++ b/dev-python/certifi/certifi-2019.11.28.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1 prefix readme.gentoo-r1
+
+DESCRIPTION="Python package for providing Mozilla's CA Bundle"
+HOMEPAGE="http://certifi.io/ https://pypi.org/project/certifi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-misc/ca-certificates"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Do not drop this patch -- this will affect system's security
+PATCHES=( "${FILESDIR}"/certifi-2018.4.16-use-system-cacerts.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ eprefixify certifi/core.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local DOC_CONTENTS="
+ In Gentoo, we don't use certifi's bundled CA certificates.
+ Instead we remove bundled cacert.pem and patch certifi
+ to return system's CA certificates.
+ "
+ readme.gentoo_create_doc
+
+ # Precaution -- nothing should use bundled CA certificates
+ find "${D}" -name 'cacert.pem' -delete || die "Failed to delete bundled CA certificates"
+}