summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-17 01:55:54 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-17 02:03:45 +0100
commit60ad456ca6057ecbfebcd242f5a517466317bfab (patch)
tree6ffdbcff82e97ce1b6302cf87db2cba356184717 /dev-python/certifi
parentdev-python/elasticsearch-curator: bump to 5.6.0 (diff)
downloadgentoo-60ad456ca6057ecbfebcd242f5a517466317bfab.tar.gz
gentoo-60ad456ca6057ecbfebcd242f5a517466317bfab.tar.bz2
gentoo-60ad456ca6057ecbfebcd242f5a517466317bfab.zip
dev-python/certifi: bump to v2018.11.29
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/certifi')
-rw-r--r--dev-python/certifi/Manifest1
-rw-r--r--dev-python/certifi/certifi-2018.11.29.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
index 28776c1414ec..e15346480669 100644
--- a/dev-python/certifi/Manifest
+++ b/dev-python/certifi/Manifest
@@ -1,3 +1,4 @@
DIST certifi-2018.10.15.tar.gz 145887 BLAKE2B 695b4236d67022f12639850fdcd169570330f9dd59aee165a39143d5dc5867b8685859bc48c8af07d41b7124970748ceb97cf1f7557563865e6b3293f668393b SHA512 3324ae6c4b99dda6f48aa9f0918fe045a19b19b26fcfdcca4be93ec967b9e4112d863c982686837b327f1663e308250d56ea337caeeeeb96579e08b20fca92df
+DIST certifi-2018.11.29.tar.gz 153772 BLAKE2B fb146409560beb85731b136541012f3f114a8e35c1b0ae9a9bac31d10642dc4ff3cad6a7e722e14e1d5092f9d4e3d7f5c4acb231edd2602d3452a6c9cebd323c SHA512 6a6bf1ff98caefcdbf78a8c83e11e155368bacdd806f0ae0c6afa8f513667df6598e594b3584de61acdca3d6049f4a776937f2aa8672b602bd6db7b737f6074e
DIST certifi-2018.4.16.tar.gz 149967 BLAKE2B 4a69ec495266d54032dfabc9c17d0b1e78ad1467214f9f981feb4fae279c1f4b5f0bc3f7a643c2229b17d19e32c1ea894dc16d73b036a0b32f17faa9ac55615c SHA512 96369b318df9592ed4ff48d79ae695f89d27d85e8f5de72548fccb19ac15b83a33fb8bc096a3092d7a7f5b201af08805576888418c7927cf48b892df56464682
DIST certifi-2018.8.24.tar.gz 146866 BLAKE2B 92a609bffd777a624d18e612e2fa504b1cd4f0764f979d22bf6785158fb928d30984fba16b839f6b4066395dadcca485e6215c6f0b6b550d891673a79ea77c08 SHA512 bb0af24570dd4806bc80cd438cae42db82f820de815a6148b184f58c19cd91a03f9275815559817a84220dcbd7c87a4a7d12e35cf4a95a1dbad286a1dfecf907
diff --git a/dev-python/certifi/certifi-2018.11.29.ebuild b/dev-python/certifi/certifi-2018.11.29.ebuild
new file mode 100644
index 000000000000..3bc4e1e9e5dd
--- /dev/null
+++ b/dev-python/certifi/certifi-2018.11.29.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1 prefix readme.gentoo-r1
+
+DESCRIPTION="Python package for providing Mozilla's CA Bundle"
+HOMEPAGE="http://certifi.io/ https://pypi.org/project/certifi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-misc/ca-certificates"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Do not drop this patch -- this will affect system's security
+PATCHES=( "${FILESDIR}"/certifi-2018.4.16-use-system-cacerts.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ eprefixify certifi/core.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local DOC_CONTENTS="
+ In Gentoo, we don't use certifi's bundled CA certificates.
+ Instead we remove bundled cacert.pem and patch certifi
+ to return system's CA certificates.
+ "
+ readme.gentoo_create_doc
+
+ # Precaution -- nothing should use bundled CA certificates
+ find "${D}" -name 'cacert.pem' -delete || die "Failed to delete bundled CA certificates"
+}