summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-09-09 14:27:51 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-01-10 21:19:53 +0000
commit3bd7fe4f2163a9e4d1edf99a84881b3cd66c8ba9 (patch)
tree843d4d5af9af32b8db61be650056264e782a2f22 /dev-python/cffi
parentdev-python/pillow: Fix cross-compiling of 5.4.1 (diff)
downloadgentoo-3bd7fe4f2163a9e4d1edf99a84881b3cd66c8ba9.tar.gz
gentoo-3bd7fe4f2163a9e4d1edf99a84881b3cd66c8ba9.tar.bz2
gentoo-3bd7fe4f2163a9e4d1edf99a84881b3cd66c8ba9.zip
dev-python/cffi: Fix cross-compiling of 1.11.5
We need to tell it the right pkg-config. Signed-off-by: James Le Cuirot <chewi@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/cffi-1.11.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/cffi/cffi-1.11.5.ebuild b/dev-python/cffi/cffi-1.11.5.ebuild
index 9cd44285b9ce..20a17f5c3fcf 100644
--- a/dev-python/cffi/cffi-1.11.5.ebuild
+++ b/dev-python/cffi/cffi-1.11.5.ebuild
@@ -7,7 +7,7 @@ EAPI=6
# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Foreign Function Interface for Python calling C code"
HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
@@ -29,6 +29,10 @@ DEPEND="${RDEPEND}
# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
DISTUTILS_IN_SOURCE_BUILD=1
+src_configure() {
+ tc-export PKG_CONFIG
+}
+
python_compile_all() {
use doc && emake -C doc html
}