summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 06:02:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 06:13:32 +0100
commit5ad0a037448fa205551f86f34903002178200ea2 (patch)
tree76ca1c97bfeb62b8a3aba4484a02a7329968ed1d /dev-python/cfn-lint
parentdev-python/aws-sam-translator: Bump to 1.42.0 (diff)
downloadgentoo-5ad0a037448fa205551f86f34903002178200ea2.tar.gz
gentoo-5ad0a037448fa205551f86f34903002178200ea2.tar.bz2
gentoo-5ad0a037448fa205551f86f34903002178200ea2.zip
dev-python/cfn-lint: Bump to 0.56.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.56.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 95689081179b..bc2ffc654b9b 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn-lint-0.54.4.tar.gz 7835716 BLAKE2B 1709adda09a08b02f4a2637af1ed2a43c096
DIST cfn-lint-0.56.0.tar.gz 8069291 BLAKE2B 6a6b0481f857e3360d2abeb372415a43ae59ed54f2c1ef08ea079f32442bea9f30a7222233cfadd398922994bc70aa78e92b8807d7386ca4b979548622d3e5f4 SHA512 f12ca4ba831c32d7c9c8079ed9d59baf6346a2c4a09cf2af0a8b258dc551b381983cb346800b37e6df3022fbb6f09ee186b44bb9ba3e0a2713c8faabce83f67b
DIST cfn-lint-0.56.1.tar.gz 8095525 BLAKE2B a9db57f17c0f5bcc0950aa61b109488154dfb67997224f7c49f35c324ada7e4881ab2bd2048df344b78668db5e26eb365712cc0a1b8d2b2349cc53c7e97b35b1 SHA512 0857139094fcfd8d935c526986319a67cddb7fc42ec1297b29f797299699d068ddbb0fdd30736b2ba1b647c905c6c7be4946915d98a23119fdb6bb70b23adef1
DIST cfn-lint-0.56.2.tar.gz 8139815 BLAKE2B 70e2657801fa7c995e6a92c36bfd49195af80b1477da651cf10a234ebf8f0aba2382e8512efc1adfeace6503d0e5afffb09e4a80e7f9464ebb6f2d53b57f84fc SHA512 9169d81b3144fa28c48372971b6197aa3a85b6365d7e45c22967ea388896b5df65e1daf6889984b8ece46b938c91c349fcde01ed9e0bf4780b549163f8948866
+DIST cfn-lint-0.56.3.tar.gz 8278034 BLAKE2B 894d30add7a193d256dc2195c0cd1d4b75f10f60abe9e37c5b0bdd84178d9559759326ad3e55d2321b99588094b436dc2dc8dff1cc561ae56dd4cee98d6b43bd SHA512 8aeaf44a626f9bfc05ebeefc8aec9211fcac1a65de681d5d700f3621631bff15e74ed644b9d0dc8af4d9b0b14802c2259dbc4ccf38594705040f5fd3af1cf482
diff --git a/dev-python/cfn-lint/cfn-lint-0.56.3.ebuild b/dev-python/cfn-lint/cfn-lint-0.56.3.ebuild
new file mode 100644
index 000000000000..7afacb42c8dd
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.56.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.42.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}