summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:27:22 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:27:22 +0300
commite0331d8b3e01e56ac791662803f771899d00f4c5 (patch)
treee7fc2996992ba8f5687c3d001b19d54a0900f6a2 /dev-python/cfn-lint
parentdev-python/paste: add 3.5.1 (diff)
downloadgentoo-e0331d8b3e01e56ac791662803f771899d00f4c5.tar.gz
gentoo-e0331d8b3e01e56ac791662803f771899d00f4c5.tar.bz2
gentoo-e0331d8b3e01e56ac791662803f771899d00f4c5.zip
dev-python/cfn-lint: add 0.61.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.61.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index f6883dd269b8..0727a41e07aa 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,2 +1,3 @@
DIST cfn-lint-0.60.1.tar.gz 9144208 BLAKE2B ff0cc155aee6fb0c72a3011a5fbaf147158d23ab8ed11426a9fc922971019cb276b74ca4e8972ddc2dbab7b1239ddb00b1d7a60281763a9773157b97ce5a8105 SHA512 8d023773a82b0b8486431e438d298e80812726d197017aafd925d6d9aa8272db99dc594f1b8f7582843ffaa9d421d6d9300f80c3bb6e932e705ae019d1cd8e21
DIST cfn-lint-0.61.0.gh.tar.gz 9252192 BLAKE2B 08a5a8648e6de27eb86629bf27fd2a40700eaa84b101c2003a2acda61b48a6ec2795dbce4dcfaa9e42664c75ab932c9cd84836d7b61bc438a586203502123d9a SHA512 3e70e5ccdc2a9909cddf9a289c5ed0d292580ecc236a1d64088fdb9ecce913814de88739ddb5b6bde5b4091e0e1efca86860157fde6e6f94e992503e4c1f83be
+DIST cfn-lint-0.61.1.gh.tar.gz 9351410 BLAKE2B 442fa5957f8816dc501e91593873c28b1b2e39ec14870b82574d4ca351f321b94a813fd351cc09c7602a177a8451d09cf8459c8aa47b683b9938654c99476e19 SHA512 63071cd1df0115624341fb64bd12a51d7bd38fe4993229a790ca09011b370487cb49397d90916f4df42b5c978cd3832e2de4cec15660ac8668e994adc0e681c3
diff --git a/dev-python/cfn-lint/cfn-lint-0.61.1.ebuild b/dev-python/cfn-lint/cfn-lint-0.61.1.ebuild
new file mode 100644
index 000000000000..8ec456de9b4f
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.61.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.45.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}