summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-03-10 20:46:47 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-10 21:31:57 -0500
commita13ffac40a3ee5e20fb3b918ebc38ca4e45d63ee (patch)
treecb6219c66c99cc78c26944863c6f523bdee0247c /dev-python/cherrypy
parentdev-python/cherrypy: 17.4.1-r1 revbump to fix dependencies (diff)
downloadgentoo-a13ffac40a3ee5e20fb3b918ebc38ca4e45d63ee.tar.gz
gentoo-a13ffac40a3ee5e20fb3b918ebc38ca4e45d63ee.tar.bz2
gentoo-a13ffac40a3ee5e20fb3b918ebc38ca4e45d63ee.zip
dev-python/cherrypy: remove 17.4.1 broken version
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/cherrypy-17.4.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/cherrypy/cherrypy-17.4.1.ebuild b/dev-python/cherrypy/cherrypy-17.4.1.ebuild
deleted file mode 100644
index db0bd2c75f89..000000000000
--- a/dev-python/cherrypy/cherrypy-17.4.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
-
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
-SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/cheroot-5.9.1[${PYTHON_USEDEP}]
- >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )"
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
- sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
- -i cherrypy/test/test_static.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "tests failed under ${EPTYHON}"
-}