summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-01-09 19:50:45 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-01-09 19:51:04 -0600
commitee1e14e632144abb123c0205cc87389cc85f03db (patch)
tree47c1221d79e28839e67baee5c767fca475f70540 /dev-python/cherrypy
parentdev-python/pytest: remove old (diff)
downloadgentoo-ee1e14e632144abb123c0205cc87389cc85f03db.tar.gz
gentoo-ee1e14e632144abb123c0205cc87389cc85f03db.tar.bz2
gentoo-ee1e14e632144abb123c0205cc87389cc85f03db.zip
dev-python/cherrypy: 18.1.0 version bump
Approved by chutzpah. Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest1
-rw-r--r--dev-python/cherrypy/cherrypy-18.1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index 92b58fc6a54e..1068ae11a817 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,2 +1,3 @@
DIST CherryPy-13.1.0.tar.gz 687221 BLAKE2B ab9c8f50026e26d171877e4e68f1c5a53fa8519190bcc577e12999cdf8a7f52be37f4ba9ed83a276a9f33676839ec63bff68aa8f9f51ddf15557e09123bf2530 SHA512 c32cf009d6a5b557560a00cde0f47a01ae481c7f60b7f340e5c99bf2d7c757e7c7cbf3ef2f4f71c172057aa09ca332f2d211cc97623ea29ba9f17287c7bc42dd
+DIST CherryPy-18.1.0.tar.gz 682792 BLAKE2B 0e072bf21656778ff8d64e87a6b19c8c5e9a3057312ebd3155b3b876432709f6f205f267cd9a105727153d458daab3e7113ffe9b3c49f911bd956bf72a19086c SHA512 58ae40ef62efeda051bf5dd35768a599094792d06a0e7c6e34c21cc5b003b700f43a02460d38a00067d255939e341fc438d248e3499fad76ccc8100f8eac94d3
DIST CherryPy-3.8.0.tar.gz 433711 BLAKE2B e1b4a554138a61e8c6313c3055723583d812e573a352d67bd5448f799e4f2f22694b800810b53cd041c665e46d9555b471d1da91c252ade96459778d7a5c07fa SHA512 25f84093e30d814c0980f7d77b98492113470c3297c66ee8652e40650757f8e2b7db01bb8de6d7a1ea9b4bed8b764502b1f563ac6f0d082970bc2d46739d19c2
diff --git a/dev-python/cherrypy/cherrypy-18.1.0.ebuild b/dev-python/cherrypy/cherrypy-18.1.0.ebuild
new file mode 100644
index 000000000000..db0bd2c75f89
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-18.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
+
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/cheroot-5.9.1[${PYTHON_USEDEP}]
+ >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
+ sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
+ -i cherrypy/test/test_static.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}