summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-25 20:59:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:01:48 +0300
commit19bec49642d598467d64e0f0777e05ce95c87100 (patch)
treed52ec4df176cfc0aa8a2d826a543716242d9ddf1 /dev-python/chump
parentdev-python/cwcwidth: Use PEP517 build (diff)
downloadgentoo-19bec49642d598467d64e0f0777e05ce95c87100.tar.gz
gentoo-19bec49642d598467d64e0f0777e05ce95c87100.tar.bz2
gentoo-19bec49642d598467d64e0f0777e05ce95c87100.zip
dev-python/chump: EAPI=8, Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/chump')
-rw-r--r--dev-python/chump/chump-1.6.0-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/chump/chump-1.6.0-r2.ebuild b/dev-python/chump/chump-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..3b551430214a
--- /dev/null
+++ b/dev-python/chump/chump-1.6.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# 'html_theme' is unset, meaning alabaster will be used
+# and sphinx depends on it
+distutils_enable_sphinx docs
+
+# The package has no test suite