summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-11-28 15:25:04 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-29 09:15:59 +0100
commit7b95f1874c2403ab082ab95877a3f7c94143988f (patch)
tree6f89bc387203ccd8d8560b14133f5868398c3b34 /dev-python/chump
parentdev-python/backports-unittest-mock: bump to 1.2.1, add doc (diff)
downloadgentoo-7b95f1874c2403ab082ab95877a3f7c94143988f.tar.gz
gentoo-7b95f1874c2403ab082ab95877a3f7c94143988f.tar.bz2
gentoo-7b95f1874c2403ab082ab95877a3f7c94143988f.zip
dev-python/chump: bump to 1.5.2, add doc
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2946
Diffstat (limited to 'dev-python/chump')
-rw-r--r--dev-python/chump/Manifest1
-rw-r--r--dev-python/chump/chump-1.5.2.ebuild42
-rw-r--r--dev-python/chump/metadata.xml1
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/chump/Manifest b/dev-python/chump/Manifest
index ff68b4955969..c5f57ded7a00 100644
--- a/dev-python/chump/Manifest
+++ b/dev-python/chump/Manifest
@@ -1 +1,2 @@
DIST chump-1.5.1.tar.gz 9370 SHA256 5aa5a1a4a0c0baa610e742018f5cce508fa4c980b15188664de0d3834e76b857 SHA512 778e043e4641b433a03860f1b1b144cdd34d0f79fb20ec0801cea1e1473eade8dd5211ffca391a57eb1f01456ec33cef4db6359839e7e39eab169411d00471e3 WHIRLPOOL dd78cd570060e75ab74e9e42e311dc3b0f096cc0fec588ad6c8378be314ec675b1557f172db945091d09caf10e26b04ec1ff92ffeb30a32df8254b2048728089
+DIST chump-1.5.2.tar.gz 12920 SHA256 e2274993917373dc2a25c52fb4c23d26e11d11c987d882ece8683d4f55eb64d3 SHA512 6b836bac1ab38c88084f9d6608a9ed88b305847faabcf5de6c13d587e91dc92b21334877cb9290dd56873de40be92f31f2bab3a345c7a7e62259004f5762cda4 WHIRLPOOL 442bd78fb5ad9f506ef903f1193ae98a66c29a5a10321512a40c64cca326b324ec8717538f0ba5542d26f4523badd5d4f0dd0b99e123918c6862d4214fd5be63
diff --git a/dev-python/chump/chump-1.5.2.ebuild b/dev-python/chump/chump-1.5.2.ebuild
new file mode 100644
index 000000000000..129cd212bbe1
--- /dev/null
+++ b/dev-python/chump/chump-1.5.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+# PyPI tarballs currently don't contain docs
+# https://github.com/karanlyons/chump/pull/10
+# Releases are not tagged on GitHub
+# https://github.com/karanlyons/chump/issues/9
+SRC_URI="https://github.com/karanlyons/${PN}/archive/0cd59e14267858ab6623d7aa42badc6caa9b8edf.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # Force sphinx to use the standard theme
+ use doc && READTHEDOCS=True emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/chump/metadata.xml b/dev-python/chump/metadata.xml
index b0090344cbbd..577981393aed 100644
--- a/dev-python/chump/metadata.xml
+++ b/dev-python/chump/metadata.xml
@@ -13,5 +13,6 @@
<remote-id type="pypi">chump</remote-id>
<remote-id type="github">karanlyons/chump</remote-id>
<bugs-to>https://github.com/karanlyons/chump/issues</bugs-to>
+ <changelog>https://github.com/karanlyons/chump/blob/master/HISTORY.rst</changelog>
</upstream>
</pkgmetadata>