summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-04 14:56:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-04 17:24:36 +0100
commitf0a1ebf34d01faf4870b52dde541ff3a2425675e (patch)
treea076211b8be9ead8881aaa3bc9f7b0ca39929658 /dev-python/clang-python/clang-python-10.0.0_rc3.ebuild
parentdev-ml/llvm-ocaml: Bump to 10.0.0rc3 (diff)
downloadgentoo-f0a1ebf34d01faf4870b52dde541ff3a2425675e.tar.gz
gentoo-f0a1ebf34d01faf4870b52dde541ff3a2425675e.tar.bz2
gentoo-f0a1ebf34d01faf4870b52dde541ff3a2425675e.zip
dev-python/clang-python: Bump to 10.0.0rc3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python/clang-python-10.0.0_rc3.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-10.0.0_rc3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-10.0.0_rc3.ebuild b/dev-python/clang-python/clang-python-10.0.0_rc3.ebuild
new file mode 100644
index 000000000000..fc791c8175c3
--- /dev/null
+++ b/dev-python/clang-python/clang-python-10.0.0_rc3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}