summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-26 23:20:59 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-27 10:44:35 +0200
commit373fd5d47be781cdb147abecf680a6ae718f51b6 (patch)
tree832e3a289e9c2b85801114941eff4cf5c18dd547 /dev-python/clang-python/clang-python-6.0.1.ebuild
parentsys-devel/clang: Bump to 6.0.1 (diff)
downloadgentoo-373fd5d47be781cdb147abecf680a6ae718f51b6.tar.gz
gentoo-373fd5d47be781cdb147abecf680a6ae718f51b6.tar.bz2
gentoo-373fd5d47be781cdb147abecf680a6ae718f51b6.zip
dev-python/clang-python: Bump to 6.0.1
Diffstat (limited to 'dev-python/clang-python/clang-python-6.0.1.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-6.0.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-6.0.1.ebuild b/dev-python/clang-python/clang-python-6.0.1.ebuild
new file mode 100644
index 000000000000..5d6eaf45c6cd
--- /dev/null
+++ b/dev-python/clang-python/clang-python-6.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit python-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-fbsd"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}/bindings/python
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}