summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-30 13:16:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-30 20:13:49 +0200
commit715e9fa983d7deb5acb68ee447e63cdb928e1015 (patch)
treed05b806ffa9fe70b917efbcab1b05b05b9e11a7f /dev-python/clang-python
parentsys-devel/clang: Bump live to 14* (diff)
downloadgentoo-715e9fa983d7deb5acb68ee447e63cdb928e1015.tar.gz
gentoo-715e9fa983d7deb5acb68ee447e63cdb928e1015.tar.bz2
gentoo-715e9fa983d7deb5acb68ee447e63cdb928e1015.zip
dev-python/clang-python: Bump live to 14*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/clang-python-14.0.0.9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-14.0.0.9999.ebuild b/dev-python/clang-python/clang-python-14.0.0.9999.ebuild
new file mode 100644
index 000000000000..921f7735340a
--- /dev/null
+++ b/dev-python/clang-python/clang-python-14.0.0.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}