summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-07 14:24:50 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 15:04:12 +0200
commitf47b489deb2bf64b4ab2ba92a427e77e55acf1f8 (patch)
tree78fadfd433316b319f02e54428c3b00221259f05 /dev-python/cli_helpers/cli_helpers-1.2.1.ebuild
parentdev-python/pygments: Bump to 2.4.2 (diff)
downloadgentoo-f47b489deb2bf64b4ab2ba92a427e77e55acf1f8.tar.gz
gentoo-f47b489deb2bf64b4ab2ba92a427e77e55acf1f8.tar.bz2
gentoo-f47b489deb2bf64b4ab2ba92a427e77e55acf1f8.zip
dev-python/cli_helpers: Bump to 1.2.1, add tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-1.2.1.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-1.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild b/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild
new file mode 100644
index 000000000000..c87fb19bc66a
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-1.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="http://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]' -2)
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}