summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-05 11:03:10 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-05 11:03:10 -0400
commita80131612b5a065f1e6bf39975255e4646467483 (patch)
treece296904055299ca07259321b1ce5515b34b5879 /dev-python/cli_helpers/cli_helpers-9999.ebuild
parentdev-python/terminaltables: New Package, required for dev-db/mycli (diff)
downloadgentoo-a80131612b5a065f1e6bf39975255e4646467483.tar.gz
gentoo-a80131612b5a065f1e6bf39975255e4646467483.tar.bz2
gentoo-a80131612b5a065f1e6bf39975255e4646467483.zip
dev-python/cli_helpers: New Package; required for dev-db/mycli
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-9999.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-9999.ebuild b/dev-python/cli_helpers/cli_helpers-9999.ebuild
new file mode 100644
index 000000000000..95d68a34211d
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EGIT_REPO_URI="https://github.com/dbcli/${PN}.git"
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python helpers for common CLI tasks"
+
+HOMEPAGE="http://cli-helpers.rtfd.io/"
+SRC_URI=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/terminaltables[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+"