summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-10 16:09:18 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-10 16:09:39 +0000
commit628d78f9b7872b1bdb417cb3fd8839f3425479a1 (patch)
tree503f42a86a69aa5785903fe5cad87ca76c9877d8 /dev-python/cliapp/cliapp-1.20170823.ebuild
parentapp-arch/stuffit: Update Manifest hashes. (diff)
downloadgentoo-628d78f9b7872b1bdb417cb3fd8839f3425479a1.tar.gz
gentoo-628d78f9b7872b1bdb417cb3fd8839f3425479a1.tar.bz2
gentoo-628d78f9b7872b1bdb417cb3fd8839f3425479a1.zip
dev-python/cliapp: Version Bump
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-python/cliapp/cliapp-1.20170823.ebuild')
-rw-r--r--dev-python/cliapp/cliapp-1.20170823.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cliapp/cliapp-1.20170823.ebuild b/dev-python/cliapp/cliapp-1.20170823.ebuild
new file mode 100644
index 000000000000..6ca847d60c1a
--- /dev/null
+++ b/dev-python/cliapp/cliapp-1.20170823.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for Unix-like command line programs"
+HOMEPAGE="http://liw.fi/cliapp/"
+SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/cliapp/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+# test deps not supporting python 3
+RESTRICT="test"
+
+MY_DEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ "
+
+DEPEND="${PYTHON_DEPS}
+ ${MY_DEPEND}"
+# test? ( >=dev-python/CoverageTestRunner-1.11 dev-python/pep8 )
+# "
+
+RDEPEND="
+ ${MY_DEPEND}
+ "
+
+src_test() {
+ addwrite /proc/self/comm
+ distutils-r1_src_test
+}
+
+python_test() {
+ ${PYTHON} -m CoverageTestRunner --ignore-missing-from=without-tests || die
+}