summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-12-08 13:45:29 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-13 11:07:42 -0500
commitb806411c7c5cd74829aef12171bdcc52b8c0a2d2 (patch)
tree718afa36ee0efe8ad61b719a3649060808bb1cde /dev-python/click-log
parentsys-cluster/maui: drop old (diff)
downloadgentoo-b806411c7c5cd74829aef12171bdcc52b8c0a2d2.tar.gz
gentoo-b806411c7c5cd74829aef12171bdcc52b8c0a2d2.tar.bz2
gentoo-b806411c7c5cd74829aef12171bdcc52b8c0a2d2.zip
dev-python/click-log: apply distutils_enable_tests, add py37 compat
Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/click-log')
-rw-r--r--dev-python/click-log/click-log-0.1.8.ebuild11
-rw-r--r--dev-python/click-log/click-log-0.2.1.ebuild11
-rw-r--r--dev-python/click-log/click-log-0.3.2.ebuild11
3 files changed, 9 insertions, 24 deletions
diff --git a/dev-python/click-log/click-log-0.1.8.ebuild b/dev-python/click-log/click-log-0.1.8.ebuild
index 892e37863876..0a7775893540 100644
--- a/dev-python/click-log/click-log-0.1.8.ebuild
+++ b/dev-python/click-log/click-log-0.1.8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
@@ -13,15 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
DOCS=( README.rst )
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest
diff --git a/dev-python/click-log/click-log-0.2.1.ebuild b/dev-python/click-log/click-log-0.2.1.ebuild
index 892e37863876..0a7775893540 100644
--- a/dev-python/click-log/click-log-0.2.1.ebuild
+++ b/dev-python/click-log/click-log-0.2.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
@@ -13,15 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
DOCS=( README.rst )
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest
diff --git a/dev-python/click-log/click-log-0.3.2.ebuild b/dev-python/click-log/click-log-0.3.2.ebuild
index 9568fa319e09..7d9bc6d73ff9 100644
--- a/dev-python/click-log/click-log-0.3.2.ebuild
+++ b/dev-python/click-log/click-log-0.3.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
@@ -13,15 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
DOCS=( README.rst )
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest