summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-02-21 14:20:11 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-21 14:20:11 +0100
commit4f344d42e9185bdbded8753b21fdb0d2129b4daa (patch)
tree9fec9f92799d71e8a5198f4dbcebda4e610c2fb3 /dev-python/click
parentdev-python/elasticsearch-py: Add python 3.9 (diff)
downloadgentoo-4f344d42e9185bdbded8753b21fdb0d2129b4daa.tar.gz
gentoo-4f344d42e9185bdbded8753b21fdb0d2129b4daa.tar.bz2
gentoo-4f344d42e9185bdbded8753b21fdb0d2129b4daa.zip
dev-python/click: Add python 3.9
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/click-6.7-r2.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-python/click/click-6.7-r2.ebuild b/dev-python/click/click-6.7-r2.ebuild
index e6afce4e9b40..4a02313d5fb2 100644
--- a/dev-python/click/click-6.7-r2.ebuild
+++ b/dev-python/click/click-6.7-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 pypy3 )
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
inherit distutils-r1
@@ -14,24 +14,17 @@ HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
+IUSE="examples"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+distutils_enable_tests pytest
PATCHES=(
# From upstream, can be removed in next release.
- "${FILESDIR}/${PN}-6.7-fix-tests.patch"
+ "${FILESDIR}"/${PN}-6.7-fix-tests.patch
# From upstream, can be removed in next release.
- "${FILESDIR}/${PN}-6.7-support-sphinx-1.7.patch"
+ "${FILESDIR}"/${PN}-6.7-support-sphinx-1.7.patch
)
-python_test() {
- emake test
-}
-
python_install_all() {
use examples && dodoc -r examples
distutils-r1_python_install_all