summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/clientcookie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/clientcookie')
-rw-r--r--dev-python/clientcookie/Manifest1
-rw-r--r--dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild26
-rw-r--r--dev-python/clientcookie/metadata.xml15
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/clientcookie/Manifest b/dev-python/clientcookie/Manifest
new file mode 100644
index 000000000000..39857e610f80
--- /dev/null
+++ b/dev-python/clientcookie/Manifest
@@ -0,0 +1 @@
+DIST ClientCookie-1.3.0.tar.gz 130974 SHA256 cd51a411ffbbce76a4046a42f43711fc2674db05201e649c6035aa8178874797 SHA512 3a42660557bbcda76f7e63fb4fea0ccaa15967e8e6991d65dc72921efb8cec475f7ebfbfe963e5577f7dfbacebb84488b7bb5e6e4e913e863e54c0faf0b4e9f5 WHIRLPOOL 892e206238d5954b2f16610bfc52d89c8c8f82fecddc6ee519c931a007ed9d261dd5cb7e0832c3175bb696888fbb7d488b1a04094bba3d940a5b57344f3b78c6
diff --git a/dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild b/dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..86404f8502a0
--- /dev/null
+++ b/dev-python/clientcookie/clientcookie-1.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="ClientCookie-${PV}"
+
+DESCRIPTION="Python module for handling HTTP cookies on the client side"
+HOMEPAGE="http://wwwsearch.sourceforge.net/ClientCookie/ http://pypi.python.org/pypi/ClientCookie"
+SRC_URI="http://wwwsearch.sourceforge.net/ClientCookie/src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc x86 ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="*.txt"
diff --git a/dev-python/clientcookie/metadata.xml b/dev-python/clientcookie/metadata.xml
new file mode 100644
index 000000000000..ca527c7bee0a
--- /dev/null
+++ b/dev-python/clientcookie/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+ClientCookie is a Python module for handling HTTP cookies on the client
+side, useful for accessing web sites that require cookies to be set and
+then returned later. It also provides some other (optional) useful stuff:
+HTTP-EQUIV and Refresh handling, automatic adding of the Referer [sic]
+header, automatic observance of robots.txt and lazily-seek()able responses.
+These extras are implemented using an extension that makes it easier to add
+new functionality to urllib2. It has developed from a port of Gisle Aas'
+Perl module HTTP::Cookies, from the libwww-perl library.
+</longdescription>
+</pkgmetadata>