summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/cliff-tablib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/cliff-tablib')
-rw-r--r--dev-python/cliff-tablib/Manifest1
-rw-r--r--dev-python/cliff-tablib/cliff-tablib-1.1.ebuild28
-rw-r--r--dev-python/cliff-tablib/metadata.xml9
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cliff-tablib/Manifest b/dev-python/cliff-tablib/Manifest
new file mode 100644
index 000000000000..46cf1964b4b2
--- /dev/null
+++ b/dev-python/cliff-tablib/Manifest
@@ -0,0 +1 @@
+DIST cliff-tablib-1.1.tar.gz 80508 SHA256 4a8ed81f6678e76d0e0497f2708d0fe5d2b83ec442a03f982aaa711a08c74139 SHA512 26beea20ca1ba5c96276ce974c24bab572c6efebfe44ef45bd3ee6197593a34bf29843676a4e37fe400272f3ff59f703d60ff1abda22a1ca28c2434c0f224aac WHIRLPOOL e4aabd11f43d21f47ae281dcdfad4f0c40a85cf4e51e3e344e4ba7bb3f99148f89e285e3ad4a6f8cbab854539803d0ed11b2e943da18b57fbbc81c366f58e54f
diff --git a/dev-python/cliff-tablib/cliff-tablib-1.1.ebuild b/dev-python/cliff-tablib/cliff-tablib-1.1.ebuild
new file mode 100644
index 000000000000..d2ab862a8578
--- /dev/null
+++ b/dev-python/cliff-tablib/cliff-tablib-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Formatter extensions of JSON, YAML, and HTML output in programs created by the cliff framework"
+HOMEPAGE="https://github.com/dreamhost/cliff-tablib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/tablib[${PYTHON_USEDEP}]
+ dev-python/cliff[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ # Use IUSE examples for installing the demoapp
+ use examples && local EXAMPLES=( demoapp/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/cliff-tablib/metadata.xml b/dev-python/cliff-tablib/metadata.xml
new file mode 100644
index 000000000000..0d6cfb59d5e2
--- /dev/null
+++ b/dev-python/cliff-tablib/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <upstream>
+ <remote-id type="pypi">cliff-tablib</remote-id>
+ <remote-id type="github">dreamhost/cliff-tablib</remote-id>
+ </upstream>
+</pkgmetadata>