summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 21:41:14 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 22:26:10 -0600
commit62bd6a9491ab97ee236eac89eddc31fb9b1726d8 (patch)
tree55aee6e55bc23f688aed1ec0d50d5a75a662fe5c /dev-python/cliff
parentdev-python/oslo-versionedobjects: bup (diff)
downloadgentoo-62bd6a9491ab97ee236eac89eddc31fb9b1726d8.tar.gz
gentoo-62bd6a9491ab97ee236eac89eddc31fb9b1726d8.tar.bz2
gentoo-62bd6a9491ab97ee236eac89eddc31fb9b1726d8.zip
dev-python/cliff: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-2.4.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 64695e53d585..d50a31d9f507 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,2 +1,3 @@
DIST cliff-2.0.0.tar.gz 51837 SHA256 6e219dc3ed80a23e3dc5c88b741f3997b8450581c1d2572bde14b2dfa556d782 SHA512 6bc53c4958f21e4b67a71a97a7413bb6760065987e92c922b5de6b748deb55b5bd711c1de962573c326d0c451c755c5fad2cc0458b2d4eb4ec67bcaa750d20bc WHIRLPOOL 132ec260e55bec0dba40433abf580e5f11f265152dd8497cc42b42c5cb576284a6c0c7f867fd0ddbab2205ac27c1108e7fbd13ccfdae9ddba84cf17c2246d366
DIST cliff-2.2.0.tar.gz 57767 SHA256 a12a6bd3cf9085f0e0589c5019037ac4ee410413abbb76189fa62695f79f84fc SHA512 b6f1c55c676e040c0ca8996a0bbb33331c83d102c17cc62700014fec47f8135ba1c9185cbf10e60401799490b2f02b8471ca4d130d1ead978f6076bf29e36de0 WHIRLPOOL 3286a91d1c0af07e408244f3179a53f6a54529b611d63adc74b12c9ea851ca38e5f32cec0039f53e97848e64fa36e1b20bcb90108d6d55d286ce638e1955c798
+DIST cliff-2.4.0.tar.gz 58088 SHA256 cc9175e3c2a42bc06343290a1218bc6b70f36883520b2948f743c5f9ae917675 SHA512 2683e9c0ba56a473abfb08a4def07a1025930b9af100ba18ade7dccf1c73f2d4ddec1cd109ce948e379e41481556791c7620289af910243885a52273d936aef4 WHIRLPOOL b762fffc735ad70cc91f1dfb7a67bc62d07b1e71150e86ddbce8b8ca67ae6fce2de8fa6181b429bb616f421846dc08cc0f519b66b6717cc7ffadc4f2c2d52f45
diff --git a/dev-python/cliff/cliff-2.4.0.ebuild b/dev-python/cliff/cliff-2.4.0.ebuild
new file mode 100644
index 000000000000..08b363afa4c5
--- /dev/null
+++ b/dev-python/cliff/cliff-2.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ )
+"
+# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.0.7[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
+ >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ "
+
+python_compile() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}