summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 20:55:58 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 20:55:58 -0500
commit66911aea89d62d93889778ae5be8c2bfa0841420 (patch)
treefa17ad88cfabb3853ca3ca55fd9d99480b243088 /dev-python/cliff
parentdev-python/unicodecsv: adding py33 (diff)
downloadgentoo-66911aea89d62d93889778ae5be8c2bfa0841420.tar.gz
gentoo-66911aea89d62d93889778ae5be8c2bfa0841420.tar.bz2
gentoo-66911aea89d62d93889778ae5be8c2bfa0841420.zip
dev-python/cliff: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-2.0.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index d4d754bf32e3..6eeef76244bb 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -3,3 +3,4 @@ DIST cliff-1.12.0.tar.gz 48052 SHA256 7609abc1789522fc4e228ea5567a9fd1db39638503
DIST cliff-1.13.0.tar.gz 46997 SHA256 2b92d12cf1aa59c0cf1914b4b6b02b78daadac890a53d0e6b71b5220661ab9e0 SHA512 fd2842041bb407472c405cb362e25b87dc6a59dd7f2335254a0484e030c685e38c0290c41b5e2be005bbd5a74589c1d1086a7caf379507d463704ad4614c1aeb WHIRLPOOL 57e654e9c558098d132e941b197e7c0cfc4654a3d339034132cc645898009a82c9d0cb98ffa1def9e81ce93cd8e347185a9d7e680765f43dca2e7dc25cf1737c
DIST cliff-1.14.0.tar.gz 46656 SHA256 8aaea62a7ccfad406bc765765a4b6aef9883dacf90bccaaf15c87598b17c1017 SHA512 29081041a588807856a4744d1bcf2b8b46110ba62281fe56dce5c31759d90c5f96010f72e3c1d32d16998a7b5eab905f1349472178fb3f887682acbc5a622c9c WHIRLPOOL 2c725e74e8fdb4346db134799f980711d614d3293156dfe7e6c2e183ea5821df1a63a65b2ee7d33728d2aafdf23a0fa4f2a30494c6c3680c050b0ecf744e72a4
DIST cliff-1.8.0.tar.gz 44863 SHA256 a761e19cf9375739a5db94bba6fbcd2ed1a23484190740bb9631eeb01efdfebf SHA512 f16eeaf911bf9e613f7a6f85651a48dc43fe373d5ee09523c977ec8f80996610965683dc66b3e4c40dc5c65219046bd015ff4b85e98c70f5a60a0e03e34a58d5 WHIRLPOOL 108ea36366a1e82d899c523378101eb4c93a63ba049369b901b4a9586ae7b7801b3e82d705e52aee4feba423d244a76fbc2900dcfbc32295b8f5f451fc211968
+DIST cliff-2.0.0.tar.gz 51837 SHA256 6e219dc3ed80a23e3dc5c88b741f3997b8450581c1d2572bde14b2dfa556d782 SHA512 6bc53c4958f21e4b67a71a97a7413bb6760065987e92c922b5de6b748deb55b5bd711c1de962573c326d0c451c755c5fad2cc0458b2d4eb4ec67bcaa750d20bc WHIRLPOOL 132ec260e55bec0dba40433abf580e5f11f265152dd8497cc42b42c5cb576284a6c0c7f867fd0ddbab2205ac27c1108e7fbd13ccfdae9ddba84cf17c2246d366
diff --git a/dev-python/cliff/cliff-2.0.0.ebuild b/dev-python/cliff/cliff-2.0.0.ebuild
new file mode 100644
index 000000000000..09351be0c740
--- /dev/null
+++ b/dev-python/cliff/cliff-2.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}] )
+ doc? (
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}] )
+ "
+# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ "
+
+python_prepare_all() {
+ sed -i '/^argparse/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}