summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-29 09:28:00 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-29 10:15:33 +0200
commite27a8476a9a1b61e6055d5b5854b580181838c9c (patch)
treed28fdce14690b80d0248f2d97e7ee6ab8dae3f9a /dev-python/cloudpickle/cloudpickle-1.2.1.ebuild
parentdev-python/serpent: Bump to 1.28 (diff)
downloadgentoo-e27a8476a9a1b61e6055d5b5854b580181838c9c.tar.gz
gentoo-e27a8476a9a1b61e6055d5b5854b580181838c9c.tar.bz2
gentoo-e27a8476a9a1b61e6055d5b5854b580181838c9c.zip
dev-python/cloudpickle: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cloudpickle/cloudpickle-1.2.1.ebuild')
-rw-r--r--dev-python/cloudpickle/cloudpickle-1.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/cloudpickle/cloudpickle-1.2.1.ebuild b/dev-python/cloudpickle/cloudpickle-1.2.1.ebuild
new file mode 100644
index 000000000000..c99bc7ac83d6
--- /dev/null
+++ b/dev-python/cloudpickle/cloudpickle-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Extended pickling support for Python objects"
+HOMEPAGE="https://pypi.org/project/cloudpickle/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # -s unbreaks some tests
+ # https://github.com/cloudpipe/cloudpickle/issues/252
+ pytest -svv || die "Tests fail with ${EPYTHON}"
+}