summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-14 19:51:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-14 20:55:39 +0200
commitaa006415bcc6100636481f1818a9c147096e83c8 (patch)
tree891df5b49e55978dc0ae577ae1f333229f84893e /dev-python/cloudpickle
parentsys-fs/squashfs-tools-ng: Version bump to 1.0.0 (diff)
downloadgentoo-aa006415bcc6100636481f1818a9c147096e83c8.tar.gz
gentoo-aa006415bcc6100636481f1818a9c147096e83c8.tar.bz2
gentoo-aa006415bcc6100636481f1818a9c147096e83c8.zip
dev-python/cloudpickle: Port to py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cloudpickle')
-rw-r--r--dev-python/cloudpickle/cloudpickle-1.4.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/cloudpickle/cloudpickle-1.4.1.ebuild b/dev-python/cloudpickle/cloudpickle-1.4.1.ebuild
index b938479134b0..94fc9aa0dad0 100644
--- a/dev-python/cloudpickle/cloudpickle-1.4.1.ebuild
+++ b/dev-python/cloudpickle/cloudpickle-1.4.1.ebuild
@@ -2,27 +2,27 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="Extended pickling support for Python objects"
-HOMEPAGE="https://pypi.org/project/cloudpickle/"
+HOMEPAGE="
+ https://pypi.org/project/cloudpickle/
+ https://github.com/cloudpipe/cloudpickle/"
SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
)"
+distutils_enable_tests pytest
+
python_test() {
# -s unbreaks some tests
# https://github.com/cloudpipe/cloudpickle/issues/252