summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-10 06:38:28 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-10 07:18:55 +0100
commit4b978d2c4a3a9d46801b4d0a3564f691c7f5801d (patch)
tree037b587e3bd84c6d77b613c30ba91e9dd1295da5 /dev-python/cmd2/cmd2-0.9.23.ebuild
parentmedia-gfx/gscan2pdf: remove old 2.6.1 (diff)
downloadgentoo-4b978d2c4a3a9d46801b4d0a3564f691c7f5801d.tar.gz
gentoo-4b978d2c4a3a9d46801b4d0a3564f691c7f5801d.tar.bz2
gentoo-4b978d2c4a3a9d46801b4d0a3564f691c7f5801d.zip
dev-python/cmd2: Bump to 0.9.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cmd2/cmd2-0.9.23.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-0.9.23.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/cmd2/cmd2-0.9.23.ebuild b/dev-python/cmd2/cmd2-0.9.23.ebuild
new file mode 100644
index 000000000000..96e135a24d86
--- /dev/null
+++ b/dev-python/cmd2/cmd2-0.9.23.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}